Ariela - Home Assistant Android Client


#1485

Unfortunately that’s not a cause of this issue. I’ve got device name provided. Furthermore I tried to type there several different names. Te issue is still present :frowning:


#1486

Please enable debug mode in Ariela, reproduce again the issue and send me the logs so i can investigate. Thank you.


#1487

I’ve send log to you via contact form :slight_smile:


#1488

I have checked my email over past 5 minutes and i couldn’t find anything from you yet.


#1489

Ok, now it’s send :slight_smile:


#1490

Hi,
Can you confirm that you installed the script from here: https://github.com/MCrissDev/HANotify ?


#1491

I copied once again this script, restarted HA and now everything is working just fine. Thanks :slight_smile:


#1492

Glad to hear its working.


#1493

I was finally able to get everything working. I wound up deleting the custom_components and the fcm-android folders. I then re-created them in the configurator. I then created an empty notify.py file in that folder then copied the contents of the fcm-android.py file to it. After that everything worked perfectly. I was also able to get notifications working great so far. It must have been a permissions issue.


#1494

Glad to hear its working. Please let me know if you have any other issues.


#1495

Hi!

First and foremost, thanks for all your hard work. I have a few requests and an issue…

Requests:

  • ibeacon support
  • disable toast / vibrate for “Failed to connect…” error
  • more than launch apps, control phone wifi / bluetooth / screen timeout value / sound profile / etc. (similar to Trigger android app and Hass Phone Control)
  • when persistent notification is enabled, add option to hide status bar icon

My issue right now is the app doesn’t stay running after an arbitrary amount of time and sensor data (device tracker and mqtt sensors) are not updated at frequency expected. I have the settings for persistent notification and auto-reconnect enabled. Is there something wonky with the background servicing? I am on Galaxy S7 Android 7.0, rooted/custom rom, Greenify installed but not messing with Ariela. I do have Owntrack installed as I’m evaluating, for gps device tracker, Ariela as a better option. Owntracks is a persistent notification and does reasonably good most of the time. (It has it’s own set of issues :wink: )

Thanks


#1496

hi, re-copied the fcm-android.py file via clone download and now it works. Must have done something different first time.


#1497

I am glad to hear that its working :smiley:

This is already on my TODO list.

I will add to my TODO list

I will see what i can do about this.

Maybe due to updating the app (new update is available every day) the application is updated and closed but its not starting again? You may want to check the auto start option after updating.


#1498

Is this safe? Like wouldn’t the coder be able to access your HA system as well since your giving this app access?


#1499

I am not really that kind of person that will going to toggle your lights in order to let you think ghost are present :stuck_out_tongue:


#1500

Thanks and sorry for any redundancy…

Regarding the issue I was having with unstable connection and only active when in foreground turned out being Greenify messing with me. I had not added it to the list of apps to hibernate, but somehow it made it’s way in. Odd things is GCM is supported…anyways, I disabled that and now the app keeps data up to date via mqtt.


#1501

Hello,
I am glad to hear that it was resolved. Please let me know if you have any other issues / problems.


#1502

Hello all,

Version 1.3.1.0 is out
What’s new:

  • automatically generate device name if none set
  • add support for entities with SVG icon / entity_picture
  • NEW: support for plant entities
  • NEW: Lovelace Plant card support

#1503

@lonut I haven’t scrolled through all the comments here to see if any one else is having an issue but I can definitely report that on two different OG Pixels both running updated Android 9 - Ariela 1.3.1.0 does not start up automatically on phone restart. I cannot tell you what version this problem started on (or really if it was ever working correctly in the first place.

Additionally, the GPS stops reporting when the screen is locked. One of the Pixels is running Ariela Pro, one is not. I have not yet been able to test to see if I wake up the screen with MQTT if it resumes reporting yet, I can test that later today when my wife goes out.

BTW, I just happened to find your github for Ariela. I will post these issues there. Can I suggest that you start directing people to post their bugs/features over there? I think a lot of us have a github account and it would make it much easier to figure out if bugs have been reported or if a feature has already been requested. Just a thought!


#1504

I will investigate this.

GPS reporting is not running via MQTT, instead its using websockets to do that. Anyway i will do some investigations regarding this.

I already done that several times, but it seems that is easier just to use the contact function from Ariela to report an issue. Anyway, from now on i will try to manually make a github issue for each reported bug.