Arlo cameras and sensors (entities) not showing up

I installed new Arlo cameras (Pro with base station) and configured them in configuration.yaml. I’m not getting any errors, but I’m also not finding the entity_ids on the States page of HA. Is there something more to the configuration I need to do to get them to show up? I’m assuming I need to know the names so I can use them in automations, etc.

Here are the relevant sections of my configuration.yaml (including a couple other platforms). I left off the monitored_conditions: details mentioned in the documentation as I got an error when I included the last one, and it said these entries were optional.

  - platform: arlo

  - platform: yr
  - platform: arlo

  username: !secret arlo_id
  password: !secret arlo_pw

  - platform: arlo
  - platform: alarmdotcom
    username: !secret adc_username
    password: !secret adc_password

Do you have any cameras and alarm_comtrol_panel in your state card?

Regarding the sensor, you have not put any sensors to monitor in you config,

  - platform: arlo
      - captured_today
      - last_capture
      - total_cameras
      - battery_level
      - signal_strength

Same issue.

Thanks for your reply.

Regarding the sensor entries, as I stated above, I left those off because the documentation says they are optional (will be included by default), and also because when I did include the list (copy and paste from the documentation) I got an error about signal_strength not supported (or something). My mistake was in leaving the “monitored_conditions:” line, which caused no sensors to be included. When I take that off, or include the list as you posted, I get all the sensors. THANKS! I compared your list to the documentation and still can’t figure out what it didn’t like the first time around.

I do have an alarm_control_panel.alarmcom which continues to work fine. However, there was no additional Arlo control panel listed. My mistake was, when I created a dedicated Arlo login account to use with Home Assistant I turned off “Allow Access Rights”. Because I made this a limited account it couldn’t add the panel to Home Assistant. Switching that to on gave me the control panel in HA. YAHOO!

Continuing issue (with some progress):
I now have a “sensor.arlo_cameras” entity, but there are still no camera entities. I am now getting an error in my log:

2017-11-26 14:07:12 ERROR (MainThread) [] Error while setting up platform arlo
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/helpers/", line 171, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=self.hass.loop)
  File "/usr/lib/python3.6/asyncio/", line 352, in wait_for
    return fut.result()
  File "/usr/lib/python3.6/asyncio/", line 244, in result
    raise self._exception
  File "/usr/lib/python3.6/asyncio/", line 179, in _step
    result = coro.send(None)
  File "/usr/lib/python3.6/asyncio/", line 210, in coro
    res = func(*args, **kw)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/camera/", line 61, in async_setup_platform
    cameras.append(ArloCam(hass, camera, config))
  File "/usr/lib/python3.6/site-packages/homeassistant/components/camera/", line 78, in __init__
    self._camera.base_station.refresh_rate = SCAN_INTERVAL.total_seconds()
AttributeError: 'NoneType' object has no attribute 'refresh_rate'

To me, this reads like some kind of time-out during the initialization process for the camera component of HA. I’ll research possible solutions and welcome any additional input.


1 Like

I’ve been super confused about how the Arlo alarm control panel component works. I setup a dedicated user with full access to everything and added the following to configuration.yaml.

  username: !secret arlo_username
  password: !secret arlo_password

  - platform: arlo
    home_mode_name: 'Home'

With that, I see my base station show up on the states page on the frontend. I’m also able to manually set the Arlo base station modes with automations, but I still have no control panel showing up on the frontend.

I don’t see any errors in the log aside from a few warnings about Arlo taking over 10 seconds to show up… But it does get setup.

Do you have to add anything to groups.yaml or anything else to get it to show up? Or should it just magically appear?

Also, regarding your problem, what kind of Arlo cameras do you have and what version of HA are you running?

Check me on this, but I assume (and in my experience) if you are using a groups.yaml file nothing new will automatically show up on your front end. You must add new devices and services to groups.yaml. I added it next to my panel entry and it shows up.

When I said “it couldn’t add the panel to Home Assistant” I meant that it didn’t show up in my states page at all; I wasn’t referring to the front end.

I can share my specific details another time if you have interest.

1 Base Station with 2 Arlo Pro 2, and 1 Arlo Pro connected to it.
1 Arlo Q (don’t think it’s currently supported)

Latest version of Hass.IO .58.1 on an rPi 2

I wonder if that Arlo Q is the problem. The Arlo Qs don’t hook up to the base station do they?

This part of the log makes it seem like base_station can’t be found on one of your cameras.

File "/usr/lib/python3.6/site-packages/homeassistant/components/camera/", line 78, in __init__
    self._camera.base_station.refresh_rate = SCAN_INTERVAL.total_seconds()
AttributeError: 'NoneType' object has no attribute 'refresh_rate'

The Q does not connect to base stations. In their app it has separate arm/disarm settings and shows up next to the base station as its own item (the Pros are nested under the base station and controlled more or less as a group). The Q is also a separate IP address on my home network. I can try shutting it down to see if it is somehow confusing HA, but I tend to think there’s something else going wrong.

Can someone do a fix guide for the Netgear Arlo Pro 2? I have the similar issue.

I don’t know if its related, but looks like there are others with camera support problems specifically with Not sure if you’re using, but here’s the thread:

Any news on this thread. I get the exact same issue. Can get the control panel and sensors to work but the cameras dont show up. I also have a mix of Pro and Q, suspect that is the issue.

Haven’t found any solutions yet. My log gets warnings every few minutes saying my sensors (last capture, etc) are slow to respond. I haven’t tried re-enabling FFMPEG recently, so not sure if it has been fixed while I was away.

The Arlopy is uppdatade and implemeted in HASS 0.61

Problems still occurring with .61.1 so I suspect there is yet one more patch in the works to be deployed. Likely because I have an Arlo Q in the mix.

One day, when I wasn’t looking, it started working. I get the most recent still image from the cameras on my base station on my front end web page, along with the sensor details. (I’m not using the FFMPEG component). My Arlo Q camera shows up as an entity, and I get a the most recent still image from it along with the other base station cameras, but the status of the sensors for the Q is “unknown”, so it continued to be only partially supported, so I make them hidden.

Thanks again for everyone’s input and for the fixes published.

I did the most recent upgrades and now my camera “snapshots” are not showing up. The camera sensors still seem to work but I’m not getting any pictures/feeds.

Been getting a million of theses in my logs but I was also getting them when they were working.

2018-03-16 14:00:56 WARNING (SyncWorker_3) [urllib3.connectionpool] Connection pool is full, discarding connection:

Anyone else have any problems pop up with 0.65.4 and 0.65.5?

1 Like

Yeah…I am also having issues with Arlo off late. Have temporarily disabled it. Keep an eye on for any updates on this issue.

1 Like

I looked and same issue. No snapshots.