ATOM echo not finding wifi networks after installing firmware

Hello, I’m following the $13 dollar voice assistant guide.

I can install the firmware using the connect button. But then it gets to the wifi network search and stays searching forever.

I can initialise it using and when i do it this way I can connect to wifi. But not using the guide on Home Assistant.

If I flash the voice assistant firmware and then connect using esphome. I do get an error saying “An error occurred. Improv Wi-Fi Serial not detected”

Is there anywhere I can get the voice assistant firmware from manually? So I can flash it using a tool that enables the wifi, and then do an OTA update to put the voice assist on?

I was about to post the exact same questions as you just now when I saw yours here. I ordered two M5 Echoes and tried following the same “$13” guide last night and have gotten to the same point as you. The firmware seems to flash successfully, but then it just hangs at this screen indefinitely.


Same thing also happened to me that you described if I tried to go the ESPHome dashboard route. I can get it on WiFi that way, but then don’t know how to flash it with the voice assistant firmware.

One thing I did note was that it seemed like in most videos I watching about this, the device names people would see in the browser’s serial port connection screen would have some sort of device name, whereas mine just generically says “USB Serial Port (Com 3)”


Not sure if that’s relevant or not.

Edit: Wonder if could possibly have anything to do with the 2024.5.0 version of ESPHome that was released two days ago. Wish I could downgrade my add-on to a previous version to try it, but I’m not sure that’s possible.

you can install and run older ESPHome versions at the same time.


As an update to this. I managed to get it working. I downloaded the config file from the $15 guide and made changes to the wifi section myself. Adding in the SSID and password.

I also removed the ap section. As I belive this is what was causing the infinite searching. it was in AP mode and not looking for networks.

The wifi section of my esp config now looks like this:

    - delay: 5s  # Gives time for improv results to be transmitted
    - ble.disable:
    - ble.enable:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

I then loaded in this config myself using the esphome addon on HAOS.

Hopefully this helps others!


Thank you!! This was it.