Audio not working after installing Hass.io in Docker

Hello, I have problem with audio on my PC with Ubuntu after I installed Hassio in Docker. I found out that the hassio_supervisor container automaticily create another container called hassio_audio and this container is the problem. If I stop this container the audio start works normally, but after a while, the hassio_supervisor automaticily start the audio container again and the audio stop working.

I don’t need audio in Home Assistant, so how I can disable the hassio_audio container permanently?

2 Likes

Hi, I have the same problem. I’m trying to configure pulse audio on host in order to send audio output to pulseaudio hassio_audio instance. I’m trying to follow this guide (in french) https://fluoblog.wordpress.com/2008/04/06/stream-audio-sur-un-serveur-pulseaudio/

1 Like

OMG, this is the problem? I keep trying to run mpg123 from the command line and it’s getting hung up. I reinstalled pulse audio and it would show it decoding but no audio. Going to try stopping the audio container to see if that fixes my issue…

just stopped that container… yep, that was my problem. Audio is working again.

How are you stopping the supervisor from restarting it?
EDIT: It’s in GitHub with workarounds.

well, for me when I stopped it. I didn’t realize it would restart. It did restart, but for some reason audio was still working (have not rebooted the machine). I haven’t played any announcements since then so it could very well have stopped.

Found this thread about playing audio directly with hassio and I’m going to see if that resolves my issue.

OPHoperHPO has created a Hass.io add-on that fixes the problem (it executes the pactl load-module module-suspend-on-idle command) every time the container is restarted. You can use the following repository in order to install the add-on: https://github.com/OPHoperHPO/hassio-addons. Works great.

5 Likes

Could you explain how this addon works? I install and start but it stops by itself with the next log:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Failure: Module initialization failed
[cmd] pactl exited 1
[cont-finish.d] executing container finish scripts…
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

Thanks

Thank You! I was looking for a fix for over a month. Your Add-On did the job.
Running Ubuntu 18.04 with HassIO in Docker.

It works for us. Thanks!

Hello…
I also have this problem with audio and youtube.
I tried to install the add-on in the Add-on store but was unsuccessful.
Add-on does not appear

This is truely an unforgetable memory.
I reinstall system serveral times,change from ubuntu to manjaro to linux mint and this sound problem keep happening ! Almost kill me.
And I even order a sound card from taobao. and i tore down the laptop.
suddenly i try systemctl stop docker and sound came back. Then i found here …
Really Thanks !