Wyse Thin client

Very much so. It’s silent, performant and stable. When it does eventually die, i’ll replace with another thin client.

Thank you for the fast reply. So would this work and just add SSD? https://www.ebay.com/itm/NEW-Dell-Wyse-DX0Q-5020-Thin-Client-1-5GHz-4GB-RAM-16GB-Flash-Keyboard-Mouse/401886864637?epid=17035045794&hash=item5d9252e4fd:g:yCIAAOSwW3Fdf4-q

I want Home Assistant Supervised so I am hoping I can install Ubuntu and something like VMWare Workstation Player and then install the vmdk?

Yes that looks good.

I’m not sure you can add an SSD though or flash is soldered down.

If you’re using hassio then just install x86 hassio directly. Don’t bother with another virtualization layer. That’s what I did.

Thank you. I will have to study that. I am not sure I am using the right term, but I run Home Assistant supervised that makes managing add-on and HACS easy for me. So are you saying I would install Ubuntu and then just install home assistant? Similar to what I did when I first installed on pi?

I personally used the “Intel NUC” x86 image mentioned here: https://www.home-assistant.io/hassio/installation/
IE: https://github.com/home-assistant/operating-system/releases/download/4.12/hassos_intel-nuc-4.12.img.gz

I booted a Ubuntu USB key and then dd’ed it onto the local flash storage. No need to install Ubuntu onto the box itself.

(Sorry I should mention that I did Ubuntu originally, but moved to this approach with hassio Intel NUC image)

Got it install just like I would be installing on a NUC. Are you using any Z Wave and/or Zigbee hubs? I use a Husbzb-1 and had some trouble with it on reboot when I was using VirtualBox on an old Dell Laptop with Windows 10. I recently switch to VMWare Workstation Player and it solved my reboot problem.

I bought a Dell Wyse DX0Q 5020 Thin Client 1.5GHz 4GB RAM 32GB Flash. which I think is like the one you have. It should be here in a few days so I am trying to study on the installation. I think I found the install method you referred to once I boot a Ubuntu USB key. The command I found is
gunzip -c /media/sdc1/hassos_intel-nuc-2.5.img.gz | dd of=/dev/sda bs=4M conv=fsync

Couple of questions,

Once Home Assistance is installed and configured will it auto boot on Power On
Do you have a Zwave and/or Zigbee hub connected? If so, is it working. I have a Husbzb-1

Thanks for your help.

.

Yep, that matches how I would expect to install it. Take note in my first post of the BIOS password (you’ll probably need to change BIOS settings to boot the USB key).

I think auto power on should be configurable in BIOS setup. Everything has come back for me after power outages, so I think that’s the setting I have.

I do have a Zwave USB stick. Working great. Aetotec I think?

1 Like

Thank you again. I look forward to setting this up and getting my old laptop back.

Did you update 5020 before you did the install.

Update? It’s getting wiped when you install hassio.

Thanks. I didn’t quite understand if the embedded OS would remain or if BIOS required any updating.

I installed the image on the thin client and it was working fine until I noticed it didn’t power up automatically have power loss. I tried powering it off and on and pressing DEL key but it never would go into Bios. Now it would boot from the flash - it tries to load Home Assistant then crashes with a cusor showing and it won’t boot from USB. Ahy suggestions on how to get to Bios because it looks like I corrupted Hasso with powering it off and on.

You’ll just need to spam on that key as soon as you hit the power button. It’s a timing thing.

I have tried holding it down, tapping it, and the home assistant os just keep trying to load. The DEL key seems to have to effect on it.

I disconnected the battery and now at least I was able to get into Bios and change boot order. Home Assistant must have changed the boot order?- Now I will re-image the drive.

I had the same problem…and the same solution. Once I put a new BIOS on, it was easy to change the boot order, etc.

I have one remaining problem. I went whole hog and installed Debian 10. I have home assistant, pi-hole and a choice of desktops (gnome,…). I’ve installed chrome as well. For now, it’s all installed on the flash…but I have an external SSD and my hope is to move everything (probably reinstall) using the external drive. Not sure how that will effect the speed…this is an experiment.

One problem I haven’t been able to solve is that I get no audio output…nothing through the front jack and nothing over HDMI. The adapter(s) show everywhere they should, I have the correct driver…but no sound. I’d like to run zoom on the 5020, but need sound. Any help appreciated.

I didn’t try any audio since I am only running Home Assistant on my 5020. I did look at buying another 5020 to connect to my TV for a media server so I am interested in what you find out. I am pretty sure that a Displayport to HDMI adapter will not pass audio on the 5020. I am surprised the front jack is not working. There is some good technical support for Wyse here https://www.technicalhelp.de/ Let me know how it works out.

see the following for the solution to the audio issue: