August Lock Gen4 + HomeKit

Tags: #<Tag:0x00007f739a0a7908>

Hi all, I’m trying to get the 4th gen August lock to connect to HA via HomeKit rather than the hosted August service. I’ve read through the HomeKit Controller documentation and tried the two approaches that seem available: connecting it to Wi-Fi as part of the setup process then trying to discover it, and also the " Home Assistant cannot discover my device" section that mentions going through HomeKit setup with an iPhone and then removing the device (though that’s seemingly for non-UI devices). In both cases the only HomeKit device that’s showing up is my TV.
I’m pretty sure I’ve covered my basics. I’ve factory reset it and also confirmed it’s on the same network as HA. Do some HomeKit devices just not respond to discovery broadcasts? Anything else I could try?
If it’s relevant I do already have my Abode alarm system connected through HomeKit.

1 Like

Which is the Gen4 model? Is that the new Wifi model (Which I am considering purchasing)? If you are connecting by Bluetooth only, then HA will not be able to connect through homekit_controller.

That’s the one. I did have it hooked up to WiFi for both approaches.

AFAIK, the Gen4 still uses bluetooth for HomeKit which isn’t supported by homekit_controller at this time.

1 Like

#1 How do you like it?

#2 Here is what has worked for me with other stubborn devices - Add it to HomeKit natively in your Home app. Once it is there and connected to your network, remove it from the Home app. It should still retain your wifi connection info, which will then allow it to become visible to HA. Hopefully!

Where’d you hear that? Because that seems like a good explanation.

The lock itself is awesome. Not a single issue yet. It would just suck if it requires the app. And I did do what you suggested with no luck.

Well that’s too bad. Just out of curiosity, why not use the HA integration? I get that the local direct HomeKit connection is better. But I use HA for two Yale/August locks and am very happy with it. You could always connect directly to HomeKit for Siri integration too.

I have one and did a bit of testing.

Yep, looks like this is the answer. Oh well.