Australia - Electrically Certified Hardware

Thanks Dave, I’ll pick up a couple of the Brilliant 20676/05 this weekend and give them a shot in the next week and report back.

That’s some really amazing work dude. lol I wish you were around 6 months ago when I was planning my ceiling fans :stuck_out_tongue:

Interesting question, you said how rocking esphome on that bad boy… do you have HA recognising all 5 speeds? Or is esphome still limited to 3 speeds?



Hi there,

I’m new to this. I have a bunch of bulbs and plugs that work on google assistant but now want to get to the next stage and get some wall light switch, some wall double power point and in-line switch for a extractor fan and a towel heater
for the light switches, I’m thinking going with Jinvoo.
Not sure about the power points
for the fan & heater: SONOFF TH16

Are these good options? and what would you suggest otherwise? (especially for powerpoints)
thanks for your help?

Apparently the 3 speed limit is due to Home Assistant, however someone’s posted a patch allowing them to be remapped:

Oooo maybe soon :slight_smile: hopefully they’ll allow sort of custom number as that post referenced 4 speeds.

I have a similar fan that you are working on ( . Has no light, but otherwise, 6 speeds smart wifi + remote.

The wifi module is slightly different to the one in your picture, however the daughter board looks identical. 9 pins.

I’d be very interested in one of those boards and some simple instructions if you have the time.

Hi Mike,
That picture is my replacement module, so I suspect that yours is the same pictured below. I’m hoping to do some more testing and write things up over New Years.


1 Like

I just noticed our washing machine has weird reading for power consumption using an Arlec power monitor and Tasmota 8.3.1 firmware. It is the only monitor showing these sort of readings so I assume it must be failing?

That graph appears to show voltage (“V.mean”), not power? I have plenty of devices that measure voltage and it usually fluctuates between 240-265V, and all devices on the same power circuits are pretty much aligned.
So, if other devies on the same power circuit don’t show the same behaviour then this particular one may indeed be in the process of failing.

That is what I was getting at… The devices measure power consumption but the red flag is the voltage fluctuations on just this device.

I guess I have to get the brilliant power monitoring plug at Office Works as it’s the only one left that can be flashed OTA.

Don’t think it means the device is failing, or that a brilliant device will be any different. This is the voltage reporting of one of mine.


Is yours dropping to 165 volts?

Yours is definitely not normal. If another smart plug in the same outlet does not show the issue then it’s the smart plug failing. If they both droop that low you need to get your house wiring checked. And stop using that outlet until then. Dissipating that much power could cause a fire.

1 Like

I think i will be after 4 boards as well.

1 Like

How did you go fitting it all in? The picture looks like you will go close to having it all fit together nicely

Absolutely keen to get one of these to start with, as we’ve bought one of these fans very recently and found it didn’t work in HA. Looking at replacing the other 3 fans in the house as well so touch wood it all works!

1 Like

Nice to know that are interested and that the spare boards won’t all go to waste. I’ve created a new thread for Arlec ceiling fan things: Arlec Grid Connect Ceiling Fans

Has anyone tried the Nue Home range of ZigBee lightswitches and power points, and whether or not they’d work with a Conbee II?

They seem to be reasonably priced for Australian hardware, so wouldn’t mind giving them a go

As the xmas light season approached I saw the DETA 6930HA plug in bunnings which would be perfect for fitting on a powerboard feeding the lights, connecting to HA and enabling the full suite that HA offers. To my great disappointment I was unsuccessful in flashing TASMOTA via Tuya convert so I stripped one of them down. I was even more disappointed to find a TWE2S chip inside which, after some googling, turns out is not ESP8266 and not even flashable via hardwire… bin! Sorry I dont do cloud devices.

I did have some success with other devices though, I purchased Deta 6912HA and 6922HA. Whilst I was still not able to flash OTA using Tuya convert (might have updated software from Tuya), I was able to flash using hard wire method. After some meddling with a multimeter I located the necessary pins, pics shared below.

In both cases I had to connect GPIO0 to GND whilst powering on (plugging in USB from laptop to UART device) and held for ~5s then released. Both units flashed first time and booted straight into wifi connect mode with TASMOTA. a bit of relay cycling (click click) until I applied the correct template but both units are now solid!

hope the pics help


HI, I have managed to flash the 6912 and 6922 but I struggle with the 6930. I could not use TUYA convert and a strip-down of the device does not look like an ESP8266, labelled as TWE2S (not TWE3S as per the other 2)

How did you manage to flash the 6930HA? any advice will be helpful as these are neat little devices