AUTOMATIONS Fail to Load - Following Core Update to 2022.2.3

I upgraded the HA core to version 2022.2.3. Prior to this I was running HA Core version 2022.2.2. At the same time I updated the Core, I also updated to OS 7.3. Following the upgrade I was unable to enable or edit any of the automations listed under the Automations tab. A peak in the logs reveals;

2022-02-07 14:03:33 ERROR (MainThread) [homeassistant.setup] Error during setup of component automation
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/device_automation/", line 135, in async_get_device_automation_platform
    integration = await async_get_integration_with_requirements(hass, domain)
  File "/usr/src/homeassistant/homeassistant/", line 56, in async_get_integration_with_requirements
    integration = await async_get_integration(hass, domain)
  File "/usr/src/homeassistant/homeassistant/", line 614, in async_get_integration
    integration = await _async_get_integration(hass, domain)
  File "/usr/src/homeassistant/homeassistant/", line 642, in _async_get_integration
    raise IntegrationNotFound(domain)
homeassistant.loader.IntegrationNotFound: Integration '' not found.
The above exception was the direct cause of the following exception:
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 227, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/automation/", line 232, in async_setup
    if not await _async_process_config(hass, config, component):
  File "/usr/src/homeassistant/homeassistant/components/automation/", line 637, in _async_process_config
    await async_validate_config_item(hass, raw_config),
  File "/usr/src/homeassistant/homeassistant/components/automation/", line 83, in async_validate_config_item
    config[CONF_ACTION] = await script.async_validate_actions_config(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 232, in async_validate_actions_config
    return await asyncio.gather(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 280, in async_validate_action_config
    config[CONF_DEFAULT] = await async_validate_actions_config(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 232, in async_validate_actions_config
    return await asyncio.gather(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 247, in async_validate_action_config
    platform = await device_automation.async_get_device_automation_platform(
  File "/usr/src/homeassistant/homeassistant/components/device_automation/", line 138, in async_get_device_automation_platform
    raise InvalidDeviceAutomationConfig(
homeassistant.components.device_automation.exceptions.InvalidDeviceAutomationConfig: Integration '' not found
2022-02-07 14:03:35 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of default_config. Setup failed for dependencies: automation
2022-02-07 14:03:35 ERROR (MainThread) [homeassistant.setup] Setup failed for default_config: (DependencyError(...), 'Could not setup dependencies: automation')
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
2022-02-07 14:17:39 ERROR (MainThread) [homeassistant.components.hassio.handler] Client error on /host/reboot request Server disconnected
2022-02-07 14:17:39 ERROR (MainThread) [homeassistant.components.hassio] Failed to to call /host/reboot - 

I did a backup prior to updating the Core and was able to recover HA 2022.2.2. Once restored, a hardware reboot was performed and the update tried again. This time it worked without issue. I’m now running a fully updated system.

Question is, what caused the issue and and how can I avoid such in future upgrades.

1 Like

I have this problem as well, but it only occurs after I’ve tried to add a new automation. After that it looks the same as in your log. It now looks like it’s related to adding an automation for an Aqara Opple remote (via a blueprint I have been able to succesfully use for another one of those remotes). Still investigating the issue.

Edit: After upgrading to 2022.2.9 the issue didn’t occur anymore. I had to restore a backup before I did that, though. Don’t know what happened, but it’s gone now.

I had the same problem before and after upgrading to 2022.2.9 - After I cleared the automations.yaml file, everything went back to normal. I guess that some previous former version of the UI did not properly write the automation to disc and home assistant was not able to recover from that state.