Automations not saving

I’m attempting to create automatons, but they’re not saving. I’m using a Raspberry Pi 4, 64-bit.

Steps: Settings gear -> automations -> + -> fill in the data -> save at the bottom-right.

Googling this issue shows results of people losing automations after an upgrade in 2017, and users not finding the Plus. (Which I agree isn’t a great UI choice). Any ideas? I don’t have much to troubleshoot with. Ie, am not sure how to view or edit automation.yaml.

There’s a console error: TypeError: this.cloudStatus is undefined, but I assume this is unrelated.

Do you have this in your configuration.yaml?

automation: !include automations.yaml

1 Like

Yes.

(min-char-filler)

Thank you - you’ve identified the problem; I’d inserted an extra quote somewhere in automations.yaml, invalidating the file. It’s now solved.

So you are saying that you created an automation in the automation editor and when you tried to save the automation the editor acted as if the automation saved correctly even tho it actually had not saved because you had an extra quote mark in the file somewhere? So it failed silently with no indication that it had failed?

If that’s true it sounds like a big and should be reported.

Did you try to do a config check after the automation failed to save?

That’s correct. I don’t know how to do a config check, but Burningstone’s reply prompted me to go over my configuration.yaml in detail - which is when I noticed the extra quote.

After this was fixed, the automatons I saved appeared. So, the automation system saved correctly, but the retrieval system silently failed.

go to “configuration” in the sidebar. then go to “server control”. at the top should be a button that says “check config”.

But as far the other I think I would submit a bug report.

I think I encouter to similar problem. If I will create automation in GUI, its not saved.
Or better is to say, that I can find it in automation.yaml, and automation.yaml is included in configuration.yaml, config check is ok, but that automation is not visible in GUI and automation not worked.

I have another one automation in configuration.yaml and only this automation is visible.

Sorry, I don’t use the GUI editor so I can’t really help much with that.

But are you saying the automation is in the automations.yaml file but it doesn’t show up in the GUI editor as an editable automation? Or it doesn’t show up in the GUI editor list at all?

You can have only one automation: section in your configuration.yaml.

Currently you have probably two, one for the single automation and one for the include of automation.yaml.

Yes, when I started using only automation.yaml it works.