Automations not showing up in UI

Tags: #<Tag:0x00007fc3f4626b40> #<Tag:0x00007fc3f4626a00>

Hi there

I am a long fan (and user) of Home Assistant, unfortunately, after several years of using HA, I ran into a problem I could not fix myself or find any proper solutions to here in the forum or on reddit.

The general problem is, that my automations are not shown in the UI, although they are there and working properly and have a unique id. To exclude most possible sources for errors I deleted my automations.yaml (and backed it up) and started with a fresh, empty file.
I created a new automation using the UI.

It is also showing up correctly in the entities list and it is working perfectly fine!
But it does not show up in the Automations UI on the configuration page:


For completeness here is my full automations.yaml file:

- id: '1589638561115'
  alias: Test
  description: Test
  trigger:
  - entity_id: input_text.eike_home
    from: home
    platform: state
    to: not_home
  condition: []
  action:
  - data:
      message: Test
    service: notify.mobile_app_eike

I tried restarting HA and reloading the automations in many different orders, but it does not show up at any time.

But now comes the most interesting part. When I delete my automations.yaml file and recreate an empty one (touch automations.yaml) and the restart HA I can see the automation (that is not existing anymore). The entities list shows it as “restored”, but, as you might imagine, it is not working anymore, as there is no code of it left.

Does anybody have an idea what I am doing wrong? Or did I encounter a strange kind of bug nobody encountered before?

Here is the system info from my installation:

  • Running on RapsberryPi 4
  • Using Home Assistant (hassio)
  • Version: 109.6
  • Frontend version: 20200427.2

If I forgot anything important, just let me know.

Thanks a lot in advance for any ideas or help in solving this issue.

P.S.: As I am a new user, I could not post images of all steps in this post, but I have all steps documented with screenshots in case this could help.

I suspect you’re lacking an include to the automations file. Make sure your configuration.yaml file has something like this:

automation: !include automations.yaml

Then you can go to Configuration -> Server Controls and reload automations, and hopefully that will work.

7 Likes

Hi @SeanM

Thanks a lot for your feedback.
(Un)fortunately, I have this already included in my configuration.yaml (and otherwise my automations would probably not work at all). The automations are just not shown in the UI, but they are working fine.

Do you have

default_config:

In your configuration.yaml?

Hi @francisp

Yes, I have the default_config in my configuration.yaml.

Just upgraded my R.Pi Hassio from 105 to 109 and yes I also no longer find an automatons tab in the configuration page!
Shame, that was pretty useful

what is the path to your automations.yaml file, is it in the root of config folder

And the “re-load Automations” has vanished in the Server controls page…Oh no!

https://www.home-assistant.io/blog/2019/07/17/release-96/#advanced-mode

Thanks, but no. Im in Advanced mode… no luck

I had a similar issue . That turned out too be an inactive entity. think i had changed a sensor and messed around with the tasmota settings i think i was seeing a duplicate . I restarted ha the automation showed for a few seconds so i was able to see the automations and delete them. After deleting the device from ha i was able to rediscover the device and redo the automations and they showed up properly.

Hi Yes, the Automation integration not loading on start up due to a rogue entity ID in my automations.yaml

So it looks as thought the no error of syntax, indentation, entity ID etc is tolerated.
I tidied up my automations.yaml and all is well again.

Hi all

Fortunately, I somehow got the automation back in the UI.
Unfortunately, I don’t know what caused the issue for me. I know that I did not change anything with the automations themselves. But I did (for other reasons) a lot of updates and changes to my configs and as I looked into the settings today the automations reappear somehow. So probably there was an issue hidden somewhere else in the configs for me, too.

I am experiencing this very bug as well. RPi 3B+ configuration.

I suspect, based on what was stated earlier, that is an entity is not active/found by HA, the automation is not displayed. ie: A bulb behind a smart switch. If you use the switch to turn off the bulb, then the smart bulb becomes a bad entity and HA freaks out.

If that’s the intended design, and what is actually happening, it’s probably not the best thing to do.

I find when creating scenes and automations to turn on every freaking smart device you have until your done making scenes and automations. It saves a lot of headaches and wondering where devices disappeared to.

Hi
I’ve just hit this exact same issue. Reading the issues with the configuration files, I ran the Check Home Assistant Configuration and found I’d (stupidly!) put a secret into the scenes.yaml by mistake!
The configuration checker highlighted it, and I fixed it … and my Automations appeared (and started working) again!
So it appears a yaml configuration issue has some strange effects!
I’d highly recommend the Check Home Assistant Configuration add-in. I run Hass IO, so if I mess up the configurations it usually just doesn’t start!

Whole day wasted only to find that this 1 line was missing from the configuration.yaml file. Thank-you, thank-you SeanM, I was about to give up all hope!

1 Like

Thanks @SeanM.

Messing around a lot today and figured it may have to do with this.

I finally figured it out. GUI automations are put under /automations.yaml, however in my configuration.yaml there is a line with include:

automation: !include_dir_merge_list includes/automation

The solution is to create a file in includes/automation with content (mind 2 leading spaces in my case):

  !include ../../automations.yaml

now GUI-made automations are shown in a list.

I encountered the same issue today during the testing of my own blueprint, when there should be some structure issue within it.

Reapperance:
Setup a new automation with the malfunctioning blueprint and click save,
Symptom:
New automation did not show up and all existing automations changed to grey and could be altered or see trigger history.
Solution:

  1. delete the newly added automation (the one with malfunctioning blueprint) directly in automations.yaml
  2. move the blueprint out of HA (you could save it to your own PC if you are developing it).
  3. restart Supervisor.
    Then it will be just fine.

I was not able to find out what specific structure issue will cause the fail of automation, but after comparing to the functioning blueprints and updated for multiple times, the automation was successfully added to the automation list, even the automation did not work due to incorrect settings/variable expressed in blueprint. I believe this is the best I could do. :joy: