Backup to USB setup issues

Hey everybody,

I’m running the latest on my PI based on the standard Image (Hassos).
Everything is working fine so far.

Now I tried to configure the Backup to USB of Home Assistant.
I used this guide:

But unfortunately I get stuck. I used a USB drive 32GB formatted with Fat32.
I plug the Stick, reboot HASS and find the stick being sda1.

[ 4.329795] sd 0:0:0:0: [sda] 60062500 512-byte logical blocks: (30.8 GB/28.6 GiB)
[ 4.333167] sd 0:0:0:0: [sda] Write Protect is off
[ 4.334382] sd 0:0:0:0: [sda] Mode Sense: 43 00 00 00
[ 4.334907] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[ 4.347086] sda: sda1

No I try to mount sda1 with following command from the guide “sudo mount /dev/sda1 /media/” but I get an error message:

mount: mounting /dev/sda1 on /media/ failed: No such file or directory

I checked the folder media and this is there. I tried with several commands to check if sda1 is really under dev ( but did not succeed.
Most commands do not work - I assume they are not included in hassos distribution.

I’m quite new to Linux so totally lost at this point.

Anyone any idea what I am doing wrong?

Thanks a lot!