Backward compatibility to get back to previous UI in 0.86 is Required for a smooth migration


As much as choice was given to try out Lovelace UI in 0.85, a choice to switch back to Prev. UI should be available in 0.86 to experiment and settle down with Lovelace UI. Otherwise, keeping up with the upgrades 0.86 and above will be an impossible task.

Particularly, the earlier ‘Groups.yaml’ is being completely ignored by Lovelace and this will put users to difficulty. It takes time to settle with Lovelace and we need to keep up with the upgrades also.

Please provide option for using either the old or Lovelace at user level. So that developers can work on Lovelace, while others can continue to use the old UI.

It would have been very useful and easy to migrate to Lovelace, if the groups.yaml has been considered while creating the lovelace.yaml. To rebuild the groups which was very effective and purposeful is completely lost.


Lovelace has been around for a long while now, there has to be a cutover to it being default so why not now.
The old way of using groups for views is no longer relevant in Lovelace.

I am also sure you can still use old UI in the same way you could try Lovelace and make it deafult previously, but at some time it may well be not an option

If you don’t take control in lovelace, it will use an auto-generated UI which is effectively identical to the old groups.

You can also dev-tools - click on i and down the bottom elect to load the states page which IS the old UI.

Well, as far as I could see, there is no guide on how to migrate from old UI to the Lovelace, while there is much about what Lovelace can do and why it is good.

Having build a broad setup of HA and framed desired Groups and Pages, thru group.yaml,. which was simplest to build, now suddenly there is a new set of rules to be learnt which is making the migration very difficult and undesirable.

The point I was trying to make is, if Lovelace is the forced UI and no backward compatible is available, to keep up with the Upgrade is impossible.

I tried the ‘states’ option in the info. but it did not bring back the old UI. It did nothing.


It does bring back the old UI.

Try http://ip-address:8123/states

Upgrading to .86 will convert to Lovelace where it can, there is still a requirement for you to learn and change Lovelace to your liking. Lovelace isn’t new it’s been around for a fair few releases so I disagree that it’s suddenly been made the default without any notice and there is the documention on Lovelace and plenty of posts on what it can be configured to do.

Lovelace has been there and under development for 8 months and you can still use the old UI for now. The only thing that’s changed is that Lovelace is now the default.

Agree, Lovelace has been there under development for over 6 months and there has been option to get it ready and warnings it will be made default. No questions on those.

But the default Lovelace generation has been not of much help and the documentation is there but never sufficient for a smooth and easy migration.

Since I upgraded to give it a try and found no way to get back the old UI, it threw my entire routine out-of-gear. Will try the http://ip-address:8123/states again.

I notice, often the fact HA has become a part of everyday life is overlooked, particularly with ‘breaking changes’; with so much progress taking place and being inclusive of new components at fastest pace.

The forced default UI could have waited for some more time till full UI Configuration is put in place.

While growing will bring changes, it is no more a toy to be experimental only, hence this post.

If states page is not going you the identical display you had before then there is some other issue. What are you actually seeing on your screen? Are there errors with entity_id’s? There were breaking changes that could have broken what you are seeing but really it’s hard to know what is wrong given what you have told us. Are there errors in your log?

The key point is that using the old state page will be exactly the same now on 0.86.2 as it was on 0.85.1 or earlier… if you are not seeing that, then lovelace is not your problem here there is some other issue that you are not recognising or identifying…

The auto-generated lovelace will also use the groups etc to build up a pretty good representation of your old states pages too btw - so much so that a lot of people don’t even realise they are now on lovelace!

With the fast pace development of HA I am surprised it’s took so long to make Lovelace the default.
How long is long enough, for me now, for you couple more releases,for someone else longer/shorter. There has to be a point in time and that is now, it was originally i believe supposed to be .84 but Devs decided to push out a couple of releases.
Documentation has always been an issue of open source, then again the community should always try and asssitand develop it. The sad thing I see with the community over last few days is the fact that some people who have complained it broke stuff have only made accounts on that day and have never actually contributed anything except moan.

1 Like

Hell no to Backward compatibility to get back to previous UI in 0.86

I know sometimes it a pain in the ass but each time it get broken it make me lean more and I get it looking beater

1 Like


Your prompt "If states page is not going you the identical display you had before then there is some other issue. What are you actually seeing on your screen? Are there errors with entity_id’s? "

The following ‘error’ is shown on the Homepage:
The following components and platforms could not be set up:

Please check your config.

May be this is the reason, I have lost my groups and panels as they were earlier.

Not clear what config changes are needed to overcome this error. Any help or guidance is welcome.

Hi there,

In 86.x there is a check on entity names for ‘illegal’ characters. I had the same issue as you, but a quick search for double underscores in the relevant .yaml file (and removal) fixed most of those domains. The other thing is in automations, time: has been changed - it is in the docs somewhere (I use Node Red for all automations so I didn’t have this issue).

It shouldn’t take longer than 5 mins to fix all these things to go back to the original states ui.

For the double underscores, the light and device tracker yaml files are normally the main culprits.

There is also a script that can be run to convert your config to lovelace, though I am not sure if this will work on 0.86.x - again I did this back on 0.82 so I don’t know if this will help you.

EDIT: lovelace migration tool:

EDIT2: see breaking changes:

EDIT3: I also had an issue with notifier for pushbullet and Telegram. Mine were called notify.PB and notify.TG (in caps). Needed to change to lowercase and all good in the hood

Hope this helps.

Looking at you list off top of head

group are no more think of then as cards

automation Use real time format at:‘03:00:00’
or dont have id

Scripts could have double spaces in the alias
or and dont have id

light can only have A-Za-z your entityID name

Thanks guys. Let me look into the details. (where the devil will be)…

I have the same issue. So it’s just some underscore in the ‘notify.service_name’ ?

In my case it was me using capitals


  • name: PB
    platform: pushbullet
    api_key: xxxxxxxxxxxxxxxxxxx
  • name: TG
    platform: telegram
    api_key: xxxxxx

I changed the name to ‘pb’ and ‘tg’ and it all worked ok


An update:
In 0.79.3 version, the Lovelace is working fine with the lovelace.yaml created by

However, the same is NOT alright both in 0.85.1 and 0.86.2. With the same generated lovelace.yaml, these two versions shows all cards in only one page and my panels are lost.

Do you have Yaml mode turned on in thre config?

From 0.85 unless you had this turned on in the configuration.yaml it won’t read the ui-Lovelace.yaml file and will auto generate a ui for you.

You can tell by trying tor edit it in the GUI and it will say you can’t as you are in yaml mode.

My ui-Lovelace.yaml has been working since 0.82


That’s interesting to note… ‘Enable yaml mode in config’ !

How do you do that ?

I have only this:
frontend: # Enables frontend
javascript_version: latest
themes: !include themes.yaml

Your help is much appreciated.