Balena Etcher error when installing - "something went wrong"

Short version. Etcher throws the error “something went wrong, If it is a compresssed image…” immediately after I click on Flash.

Details: I first started trying to flash to a Wyse 3040 (2gig, 8gig). I used xunbuntu (trial mode) and the first time I tried it worked great and it flashed from the HA url. But I saw that after I did a restore from my existing HA Rpi, that I had little memory left. So I thought I would install to SSD plugged into a usb. I got the above error. So I tried again to install to the internal memory again and got the error. I downloaded the file and used it directly. Nope. Tried unbunu and linux mint live. Nope.

I also have a Wyse 5060 (2 gig, 64 gig) and the same as above just trying to get in on the internal memory.

The above error comes about 2 seconds after clicking “Yes flash the disk”, as if the disks are not letting Etcher write the data. Do the partitions have to be created/formatted in a certian way?

I have installed Debian 11 and then HA on both Wyes, so I know both units work. This is driving me crazy.

Any help/hints are appriciated.


Update: I think I got it. I found a youtube of a person who installed HA on a Wyse 5060. He mentioned that he felt Etcher sometimes has trouble writing to ext partitions. He recommended to reformat the disk by creating a new device as msdos and then format the partition as fat32 I used xunbuntu (trial) → system → gparted. So far so good.

It worked and now to make a quick image using clonzilla.


First and foremost, thank you to BaitingHollow for posting this with a title of the exact problem I was having and for following up with what got things working in their situation.

I found this post as I was seeing the same error. I tried reformatting the microSD and things still didn’t work for me. I finally bumbled onto a solution and thought I’d make a comment for others who might be having similar issues.

I found a recommendation in a post from Balena support (that, or a good samaritan) to enable “Toggle Developer Tools” in the Balena Etcher View menu. This will provide better information about what’s really going on. My problem was Balena couldn’t reach the HA GitHub download for PI 4 at (I have no idea why…)

The fix… I entered the GitHub URL into my browser (Safari on MacOS Monterey) and it asked to download the file Balena is supposed to get from GitHub. Once I had the file local, I used the Balena “Install from file” option instead of “Install from URL”. When opening the file, I had to set the browse to “all files” (because it defaulted to OS files) This will allow you to select the haos_rpi4-64-9.5.img.xz file where ever you downloaded it to. From that point on, everything else worked as documented.

My PI 4 doesn’t arrive from Amazon until tomorrow so I can’t confirm everything worked 100% but I think I’m a step closer. Anyway, if BaitingHollow’s solution above doesn’t work for you, give this a try. Hope this helps.


This will also work. In this example it’s for a nuc, just change the image url to the one you need.

1 Like

Thanks so much, this was the fix for me!

Thank you so much. Had the exact same issue!
Rsolved also by manually downloading it.

PS.: Do you guys have to resize the main partition after flashing or does this HASS.OS for you on first boot?


Thank you so much for this :slight_smile:

1 Like

PS: Hass.os does the resize for you.

Yup, this worked for me - thanks!

Absolute hero!

Found the solution to all Balena Etcher problems, the version was the problem after all,
Wrote a complete guide here

1 Like

This fixed it for me!

1 Like

I was also forced to download the file, it seems that BalenaEtcher does not want to download the HomeAssistant image from the URL. Thanks for sharing.

I had the same problem with flash from URL. So I downloaded the file manually and flashed from file. Again with an error. I downloaded the image again, started again. Again an error. I got frustrated, as the SSD was brand new.
So I decided to shut down my live Linux and try to boot from SSD, although the flash process had stopped somewhere. And to my surprise, hass.os booted and told me everything was fine. Running fine now.

1 Like

Your guide was great. Thanks SimplySmartHouse
I did have another problem though.
I could not run the Live Ubuntu on my NUC.
I could however install and run Etcher (following your guide) with a Live LinuxMint system.

1 Like

That’s great, I’m glad it worked out for you.