How to Install Home Assistant On Generic x86-64 Using Live OS

How to Install Home Assistant On Generic x86-64 Using Live OS

I faced numerous issues while installing Home Assistant on my X86-64 machine using a live OS, mainly due to Balena Etcher. To prevent others from facing similar problems, I wrote a comprehensive post with clear instructions on how to install Home Assistant successfully.

Full Guide On My Website

In addition to the detailed written post, I also created a video tutorial for those who prefer visual content:

Installation Process

  1. Download And Install Balena Etcher

  2. Download Ubuntu 22.04.02 LTS

  3. Open Balena Etcher

  4. Select flash from file:

  1. Select the Ubuntu image

  2. Go to select target, and choose your USB drive, then click flash

  3. Restart your PC

BIOS setup

  1. Enter the BIOS setup using F2 (For an Intel NUC, might be different on other PC’s)

  2. Enable UEFI boot

  1. Disable Secure Boot


  1. Press F10 to save and exit

Run Live Ubuntu OS

  1. Press F10 to enter the boot menu

  2. Select your Ubuntu drive

  1. Select Try or Install Ubuntu


  1. Select Try Ubuntu


Install Balena Etcher In Ubuntu

  1. Open the terminal using Ctrl + Alt + T

  2. Copy the following commands:

sudo add-apt-repository universe -y

sudo apt update

sudo apt install libfuse2

sudo apt update

wget ''

sudo dpkg -i balena-etcher_1.14.3_amd64.deb

sudo rm balena-etcher_1.14.3_amd64.deb

sudo apt update -y

sudo apt --fix-broken install -y

  1. Paste using Ctrl + Shift + V and press Enter

  1. Open the applications menu in the bottom left


  1. Search for Balena Etcher and press Enter to open the application


Flash Home Assistant OS

  1. Copy the URL for the Generic x86-64 image from:


From the Home Assistant website

  1. Select flash from URL:


  1. Paste the Home Assistant URL

  1. Go to select target, and choose your drive, then click flash

  1. Balena Etcher should begin to flash the image

  1. Restart Ubuntu


First Boot

  1. Home Assistant should start booting

  2. You can login from your browser using


  1. Fill in the required details and click Finish

  1. You can see the Home Assistant dashboard

That’s it! You have successfully installed Home Assistant on x86 architecture.

Hope that helps.


SimplySmartHouse - TAL,

Newbie here. What can I say but a huge THANK YOU.
(For those reading this and want HAOS on a mini-PC - just follow the exact instructtions).

I tried to follow from HA instructioins to videos and etc. and spent so much wasted time but there was always something missing (Etcher issues with Cloudsmith lately, etc.) or blurry. Not this procedure. Bravo. Got it working in 10 minutes flat.

Again many many thanks.



Also a newbie here,

i struggled for hours on my NUC to get the flashed SSD with generic HA installation running. But after 1 broken USB device and 2 different Ubuntu Live versions, i found this tutorial and i worked finally!!

I knew it was about the Balena Etcher Version/Installation…


1 Like

Good guide, indeed managed to do this in one go instead of the HA one which blocked the flash process.

1 Like

May I, humbly, suggest you just look at my previous listed, very easy x86 OS install instructions (no extra install, no command lines, no Balena Etcher, just boot a Ubuntu Live USB key): Installing HAOS on a dedicated x86-64 PC - #11 by MichaelSidenius.
Basically, get a Ubuntu Live USB dongle, boot it on your target PC (“Try Ubuntu”), check your PC has the RAM, disk, net, etc you expect, fire up Firefox, surf to HA OS download page, download the HA x86 OS image, and finally “restore” this HA OS diskimage on the harddisk of your PC with the “Disks” program already on your Live USB dongle.
Sorry if I highjacked the thread.

Thanks for sharing. There are many ways to install Home Assistant OS on an x86-64. I simply tried to solve an issue that many people are currently facing when trying to install HA using the official documentation.

I guess this is an error, right?

Correct, I fixed it, thank you!

1 Like

Thanks for this. I was running into the same issue with Balena Etcher on an Ubuntu Live Image. Everything works like it should once I tried the older v1.14.3.

Yes, that’s the secret to run Balena Etcher on Ubuntu properly,
I’m glad you found it helpful.

Hi Tal, good job to document this so well! :+1:

1 Like

What is missing from the official instructions? Enable EUFI in the BIOS, Flash the image to your boot device, Boot to HAOS.

Is this the supervised version?


This is for Home Assistant Operating System, as you can see in the beginning from this topic.

Ty, tried this and it flashed my SSD. Now next problem is that it won’t boot from the SSD even if selected as first boot option.

Can my boot record be broken somehow and if so how do I fix it?

Hi dutchman, Balena Etcher seems to be the cause in a lot of issues.
You could try this: Installing HAOS on a dedicated x86-64 PC - #11 by MichaelSidenius

1 Like

A very big THANK YOU, to you for providing these instructions! My Pi 3 was slowing down and I was dreading moving it to something else like a Pi 5 etc. I settled on a Mini PC with and N95 processor($119) and I followed your instructions and they are to the T! worked perfect in less than 2 hours start to finish, my HA was running perfect on new/fast/more disk hardware! Thanks again.


That’s the best way. You can also restore a drive using this method. Bless!

1 Like