Battery level is not updating


The battery status and level are not updating, I have the track: true in known_devices.yaml but still no luck.

Can confirm that my battery level is still showing the initial value that the app reported.

Yes, exactly the same here.

Same here, I thought originally that it was due to me changing my device name in the app after first use but it seems like you guys are having it as well

I am not sure of the interval that the battery level is reported but I do know you can force the update with the up arrow in the bottom right corner of the app.

I just submitted a build to Apple that will improve this. Previously, updating battery was much rarer than I thought it was. Now, every time that you submit a location to the server whether manually or automatically it will include battery information.


The battery status only updates if my location changed? There where no updates send if i charged my phone at home while i’m at home, f. e.?

You can create automation to request every X minutes the status of your ios device


Hi, can you please give me an idea of that creation? I´m using bluetooth tracker for my iPhone. Thank you in advance.

I don’t think the bluetooth component will pass the battery level information. This information is typically passed using the iCloud component or the iOS App integration.

1 Like

I don´t like iCloud due to battery drain and gps needed to keep it working, so I´m trying to find better solution. Do you have any idea please?

is this still an issue? I cant see charging state or battery state change tested on 3 ipads and 1 iphone and same issue on all of them

Is there any solution in this problem?

Having the same problem with battery not updating since using iOS 13.4 beta on my iPhone.
Girlfriend doesn’t run this beta and battery level from that device IS updating.

I find if I’m at home I need to pull down in the app and it updates… but if I’m out and there are ‘significant location changes’ it updates… and I’m on beta app and beta iOS 13.4 n ipad/iphone…

That’s the way it always worked, but my location does change, only the battery is not

Maybe because of this?:

Received invalid webhook payload: required key not provided @ data[12][‘state’]. Got None

10:30 components/mobile_app/ (ERROR) - bericht kwam voor het eerst om 9:42 en verschijnt 5 malen

Received invalid webhook payload: required key not provided @ data[11][‘state’]. Got None

10:30 components/mobile_app/ (ERROR) - bericht kwam voor het eerst om 9:32 en verschijnt 3 malen

Maybe but mine is definitely updating…

I had the same problem with iOS 13.4 beta.

Have same problem with my iPhone XS, works fine on my wife iPhone 8. The only diffrance is that mine is on iOS beta (latest) and hers not.

Also seeing: Received invalid webhook payload: required key not provided @ data[11][‘state’] in the logs.

Reported here: