Best ir blaster for HA?

I have a tuya IR device, which doesn’t seem supported by HA. It controls my Aircon, and another controls my TV. Currently I have a ‘scene’ in tuya app, and HA script calls that scene. Just on/off for both devices. I don’t want a scene/script for every button.

I also got the tv in [DLNA Digital Media Renderer: Main Bedroom TV] but it doesn’t seem to give me any controls.

I wonder if there is a recommended IR device for HA, and what that looks like when used in HA. Is it still just scenes, or can it be a device in HA with a proper interface?


You could use one of the Boadlink RM series Universal remotes. They use to be a real pain to setup, but over time Homeassistant has made it very easy to use. Check out this video:


It seems you still create a script for every button. HA doesn’t see it as a device yet

HA will not see an IR Device as a device. The Broadlink integration will allow you to control the device, by making switches, which you can use to control the device, like this:

switch 1:
  - platform: broadlink
    mac: xx:xx:xx:xx:xx:xx
      - name: Samsung_55_tv Power
      - name: Air_Conditioner

This will create switches to control my TV and Air conditioner. Now to take this a step further you can use power monitoring plugs on these device to allow you to know if the device is on or off. i hope this clears things up.

hey @TinyDoT , thanks for your example.
I wonder where can i find these commands based on my devices.

My R4mini is fully working with the App, can it be useful to discover them ?

EDIT: just found watching the video until the end :slight_smile:

When I set my Broadlink device up, it was quite some time ago, and there were some script that would help with this. Now things are a lot easier to do with the advancement of HomeAssistant. Here are a couple of links that will help:

I hope these help : )

Tried a Broadlink RM Pro. Had compatibility issues with the router. Also it limits the WPA key to 32 characters. Any other suggestions?


1 Like

I also tried the Broadlink devices, the RM3 mini simply does not connect to a modern wifi and the other had serious problems with keeping up a stable connection.

I am now using a Tuya Zigbee IR device, works like a charm, sadly there is a bit of configuration involved in getting it running in HA, but luckily no soldering of any kind.

Description on how to get it running here:

I found a way to get around this a little. It isn’t
a solution that allows you to directly control individual IR devices as if you were in Tuya’s app, but it can still trigger actions.

I created a few tap2run scenes within the Tuya app. One I titled Theater Off while the other was Theater On. I filled each one with the commands I want run for each of the IR devices. Both of those scenes popped up into HA. Thus I was able to trigger them manually or through automations. So it’s an automation triggering an automation essentially. It isn’t perfect, but it works at least.

Note: You can use the last_learned_ir_code Attribute from the ZosungIRControl Cluster to get the IR codes a bit faster than manually going through log files. Otherwise thank you so much for this guide, very informative!

1 Like

These are easy to code and very cheap.

Thank you for this information :heart:. I updated the blog post accordingly.

If you use the tuya zigbe you don’t need to use the tuya app at all.

Have you tried doing this with a Tuya IR blaster? If so, how does it add new devices? Can you interact directly with those devices? I would be fascinated to know if someone has any experience with that.

Yes. You can read out IR commands and send them. All locally. No cloud, no other app. You just need a working zigbee stick and the zigbee tuya ir blaster.

Details in the blogpost I linked to above your message.

Wow…I’ll give it a try as I can get my hands on one of those IR units, but wow…that’s going to be a learning curve

Yeah, sadly that’s true. But luckily no soldering is involved :sweat_smile:.

Well, I snagged one of the blasters. Added it via the Zigbee stick on HA. Downloaded the py file and dropped it in the folder I created in the config directory, then added the lines to configuration.yaml. I restarted HA, but going to the device within Zigbee integration and going to manage, there is no option for “ZosungIRControl ” or “IRLearn ”, so that might have been a waste of money .