Best most powerful zigbee stick?

I don’t think you have to re-pair all of your devices. This thread might be of interest to you about the matter.

My new ZigStar is on it’s way. Will report back after it has arrived and I have swapped it with my old coordinator.

1 Like

@goliath @Tamsy According to what I know, in last version of Z2M all issues was solved and migration is smooth if you follow the book. Myself didn’t try because no CC2530 at all in my house.

1 Like

Received the ZigStar Stick v4 today. After unpacking and screwing the antenna onto the connector:

  • Opened Zigbee2mqtt.
  • Stopped the Add-on.
  • Swapped the old coordinator stick with the new ZigStar Stick v4.
  • Opened a CLI and excecuted: ls /dev/serial/by-id/
  • Noted the output (usb-1a86_USB_Serial-if00-port0 in my case).
  • Back to Zigbee2mqtt and edited Configuration: Replaced pointers to old stick with the new sick:
  port: /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0

Only if you need socat to be enabled:

master: >-
  • Saved edited conf-file and started Zigbee2mqtt.

Zigbee2mqtt came up right away and loaded all Zigbee devices installed at home. No re-pairing at all, no hassle whatsoever :+1:t3:

I will now let it settle down and monitor how the Zigbee mesh nework behaves with the new coordinator.

Is that something specific to the docker containers ? I don’t see it here :

It was preconfigured like that when I first installed Zigbee2mqtt and put a Coordinator in nearly 2 years ago… I just left it like that ever since (except for changing stick name today).

PS. It has something to do with socat athough this is not activated (anymore):

  enabled: false
  master: >-
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
1 Like

Glad to read that…but I have already bought one hahaha. I will wait to try it myself, it is time to improve the old CC2530!

Awesome. Must be zwave that’s different. Thanks for clarification. Any chance you’ll do a zwave sick with an antenna too?


@all , all discusions related to zigstar usb sticks,lan or poe coordinators will be moved to another thread:

Does anyone have any experience with this product?

eBay link:
Smartlight Zigbee CC2652P Coordinator

It seems like it has everything one would expect from a CC2652P-based coordinator along with a reasonable price of ~US$40 including worldwide shipping.

Any known issues?

We was a team of 3 people when this stick was done.
I got to path of clean, hustle free design with RF-STAR modules and another team member did on E72 from Ebyte. Personally I’m against cutting PCB board antenna and solder to antenna SMA connector. But reports from people are good.

I now tried replacing my CC2531 (which was working fine but was i was getting to the 20 device limit) with the Zigstar stick. I got almost all my devices paired yesterday using ZHA and it seemed to work fine, but today I had to restart my PI and after the restart half of my devices are not coming back online.

anyone got any suggestions?

Update: Just tried to repair an existing device and add a new one - nothing seems to be working.

Update… again… Just tried to move the USB stick from one port to another - suddenly I can add a new device and one of my other bulbs came back online… I don’t know whats happening here…

1 Like

Hi according to all feedbacks online, all people recommend to use USB extension cable to move Stick away from RPI. You can read about this problem here or here
Or try to replace from 2.0 USB to 3.0 and vice versa from 3.0 to 2.0 USB Port.

I haven’t picked up my new zigbee stick yet but the current configuration shows pty,raw,echo=0,link=/dev/ttyZ2M,mode=777 - can I use your method without repairing.

This is the only relevant part of the z2m configuration:

The part you are referring to is not necessary unless you have socat enabled.

Follow my post #83 step-by-step and you should be good without the need of re-pairing.

Yeah apparently ZHA is very sensitive regarding which USB port is used during configuration and later on… I switched the USB port and over night it seemed that everything came back online.

1 Like

Randomly it became unstable again later - where almost none of the devices was working.

Strange behavior. Let me contact you directly to check all together.

1 Like

looked at post 83 and after typing in ls /dev/serial/by-id/


port: /dev/ttyACM0


port: /dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0

following error message

Zigbee2MQTT:error 2021-09-16 17:47:10: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-09-16 17:47:10: Failed to start zigbee
Zigbee2MQTT:error 2021-09-16 17:47:10: Exiting…
Zigbee2MQTT:error 2021-09-16 17:47:10: Error: Coordinator failed to start, probably the panID is already in use, try a different panID or channel

so do I need to change panID, if so what do I change it to

You are sure you wew on version 1.21.1 already? It seems an error you would get on an older version.

I’m on 1.18 - there’s no update warning. So 1.21 is the current version.