Best practice moving from sd-card to ssd raspberry

I updated my previous post. I used SanDisk SSD Plus 120GB SSD.

With hassos, hasbian, or other? From what I’ve been reading, it seems this may not actually work for me as I’m running hassos. I’ve seen there is a usb boot compatible image of hassos here, and that may be the closest method to what I was after thus far:

I’m still unclear on the differences between running raspbian+hassio as outlined in this thread:

…versus just using that usb bootable image instead. Either way, I have to learn how to transfer my configuration to the new system.

I do not think it matters whether you have HASSIO or Hassbian. You just need to boot from something to run my steps. You also can use a different method to create a backup, e.g. on a PC. But anyway you need to fix a file system corruption on the restored image.

mgluk, I may well not understand it correctly. I have read a lot of info about how hassos cannot be made usb bootable… devs only intend to allow moving the database to ssd… etc. All the tut’s on installing hassio on ssd seem to make use of either resin-os or hassbian, then you install docker, then install hassio in docker (or something like that?). Some folks use scripts to do it, some do it manually.

I’m not sure on how that goes as I’ve never done it that way; my previous instance was just a hassio (hassos based) image for rpi flashed on an sdcard… plug it in, turn it on, and lovelace pops up to guide you through… no terminal commands to install docker, hassio, etc. OS updates are done through the gui (vs having to ssh in to use apt-get… or making a cron job, etc). This is the ‘noob’ level system I’m talking about.

Well, it works! I’ve got hassos running on my pi3b+ with no sd card:

Hi, I managed to get mine restored to an SSD and it seems to work fine, the only problem is that i can no longer update my hassio. I checked the File System and my dev/root is full. My SSD is 120gb so i am guessing the file system never expanded to use all the space. Is there anyway to expand it? Thanks.

I’m not sure there is a way after it is installed to reallocate missing drive space. How did you go about ‘restoring’? The recommended method to upgrade to ssd is with a ‘fresh install’ of hassos 3.5rc… then you restore your data from a snapshot file (which should be taken before the upgrade).

Since some folks have had issues with snapshot restores, I would also recommend first attempting to restore a full snapshot on your existing system to make sure it works before attempting to upgrade to an ssd.

This is what i did:

  1. Full snapshot of system running on SD card
  2. Install HASSIO 3.5 to ssd using Etcher (i enabled the unsafe mode just incase)
  3. Hassio booted up, created a user and made a snapshot (just so i could find the snapshot folder).
  4. I uploaded my SD Card snapshot and did a full restore.
  5. Hassio booted up fine.

As i mentioned earlier i wasnt able to update afterwards even though everything seemed to be working. It was nothing to do with the hd space as i orginally thought, it turned out to be the http entry in my config file (legacy api password i think). I removed the hole thing and it finally updated (i guess it had been depreciated).

So far i have been running it on the SSD for 2 weeks and everything works much better, logs open quicker, reboots are fast etc and i feel safer that its not suddenl going to die on me.

1 Like

Any problems after HassOS reboot or power cut?

No issues after reboot or power loss so far.

1 Like

Your SSD type? And USB adapter?



Is it a 32GB or 64GB? I bought a 64GB msata wuth a X850 board and when I use etcher to load Hassio onto it I get an error that my drive is too large. I also noticed that when it writes to the SSD it uploads between 9mb/s and 1mb/s (goes up and down never stable) and then stops for like a few seconds then uploads again…is it normal that it stops and goes like this (etcher)? It takes forever to load the Hassio image…

Also do I need to connect the 5V on the X850? I noticed it gets power from the USB so is it needed?

I get this error after etcher finishes loading the image:

So etcher keeps destroying my ssd, I have to always use disk management to revive it…

Maybe this topic can help:

So I’m stuck at burning Hassio into an mSATA ssd. No matter what I try it doesn’t partition properly or corrupts the drive.

This is the closest I got but as you can see the partitions are unknown for some reason. Is there a way to fix this?

So anyone using the X850 with a KingSpec mSATA SSD 64GB?

I can burn the latest Hassio image unto the mSATA but I get a “checksums do not match” at the end. Tried the various fixes for Win10 but nothing fixes it.

But the SSD seem to have the correct info on it so I connected it to my Pi3B+ I can see the Pi loading led blinking and I can see the ssd lights blinking but then the Pi loading led goes off and the SSD lights all stay on while the ethernet light keeps blinking. The hassio is not detected by my router. So not sure what is happening…

When I boot from SD while the SSD is connected I get this in the hardware so I believe the SSD is detected…

I moved hass.os from sd to ssd on RPi 3B+ (with X820 adapter) since a week in a very easy way:

  • made a snapshot of whole system and downloaded the tar image into pc.
  • flashed with Balena the latest release of hass.os into the ssd (ssd connected with a usb to sata adapter, no repartitioning or other stuff… just flashed!).
  • turned off home assistant and installed the ssd into X820 then connected it to pi.
  • removed the sd card and turned on the pi.
  • after some minutes connected to local ip of the new installation and resumed the home assistant backup saved to my pc (MAKE SURE TO UNCHECK HOME ASSISTANT TICK FROM THE LIST, RESUME ONLY “FOLDERS” AND “ADD-ON”)
  • take a coffee and wait 10-15 mins then go to the “old” web page of home assistant installation (the one with ssl in my case).

Now my system is up and running, without sd card, really faster than before.
Just to specify, I use a Liteon sata SSD 128Gb and a 5V 4A power adapter connected to the x820 board that route power into RPi with a usb cable (that was provided with the adapter board)

1 Like

Why did you do this?

First time I tried with all options but resulted in some error on loading so second time I unchecked “home assistant” and everything worked flawlessly.
Sincerly, I didn’t checked why and logs. Just made the empiric way :slight_smile:

Ok. I changed from SD to SSD with all on and from SSD to internal M.2 SSD in Argon One case also with all on and it worked.

I was just looking into the change from SD to SSD, i managed to flash the hassio to the ssd, I noticed that HASSIO used on 32Gb from the 240Gb, in the normal PIOS you can use raspi-config to expand the partition and use the full SSD capacity?
How did you expand the partition to use the full capacity?