Bluetooth integration doesn't work

Good morning everyone,
I use HA 2022.8.3 on a Raspberry pi4.
Today I installed Bluetooth integration but it doesn’t work.
I am attaching a screenshot of what I see on the integrations page.
I see: “Retry configuration: Timed out starting Bluetooth after 9 seconds”
If I click on button “configure” an empty popup appear.
I have tried everything but I don’t know what to think:

  • Does anyone else have the same problem myself?
  • Could it be an OS issue?
  • Did I have to buy a USB dongle?

I hope some of you can help me …Thank you all

Try to reboot the host: Settings > System > Hardware > Three dots in the top right > Reboot host.


Solution for everything:-) check error logs afterwards if it is still not working

I have restarted the host several times but nothing has changed

There is nothing in the logs.
(the level is set to ‘WARNING’)

can be a unsupported stick, like the TP-link one, mentioned on the integration webpage.

I had the same happening, changed stick for different one and everything worked immediately.

I am not using a USB stick or dongle. I would like to use the bluetooth integrated in the Raspberry pi4… it can’t be done and I have to buy a USB dongle?
I’m trying also to configure the “Passive BLE Monitor” integration but it seems that it is only for particular devices (LE)…

1 Like

I am using supervised installation and after each restart, i have to run this command and reload the integration

sudo rfkill unblock all

Without this command, if i check Bluetooth status using

sudo bluetooth scan all

I see that it is in blocked state.

My raspi400 does see a Bluetooth device and does install it, but then nothing happens it finds no bluetooth devices around my house to add.

So i get no error, but it does nothing?

Same here - I am wondering if there’s something else we have to do and everyone else knows but us …

1 Like

There are very limited number of devices supported as of now. Check my post above and run the second command if your adapter is up and active.

If not, use the first command to clear it up.

I have in devices a bluetooth adapter found - named: hci0
it seems al correct, but there is no scanning option whatever?
Sorry fuatakgun the second command for scanning does not work here I installed the HA integrated bluetooth support in the new 2022.8.3 version.
Can anybody enlighten the raspberry users how to get the in built Bluetooth working, please?

1 Like

These commands are applicable to Raspberry 4 using Supervised installation, it is how I made it worked in my system.

Where did you work the second command and what was the output?

If hci0 is found, all is good, that is your internal BT. :slight_smile:

The thing with the scanning is: only a few devices are available as of yet, but more will come. Right now, these are:

This release adds five integrations built on this: SensorPush, Govee, INKBIRD, Moat, and Xiaomi BLE. The latter also provides support for the reasonably popular Mi Flora plant sensors.

So for now, if you don’t have any of the above named devices, it will simple not find anything. End of story. :slight_smile: So if you want anything else, eg. some fancy BT sensor, it will not be discovered or work, yet. What is coming, I honestly don’t know. :slight_smile:


It might be correct in some cases, but not for me. Even though i was able to see adapter in Bluetooth integration configuration, it was throwing errors as adapter is not ready. So seeing the adapter is not enough.

That’s strange, but good to know! :+1: I always thought, if it is up and running (read: you can see it), that would be enough.

I intentionally disabled the built-in BT, so i can’t say for my system, because I had to many interferences with the Zigbee dongle I’m using.

BLE monitor should support all BLE adapters, not particular ones. If your Bluetooth is working ok, so should BLE monitor. But the sensor should be one of the ones inthe supported devices list.

I used the commands you provided in SSH.

But the answer from Patrick explained it all, I thought enabling Bluetooth would show all my tablets, phones and multimedia Bluetooth able devices in HA, by which i could integrate them in the dash. It seems it is too early for that.

Thank you all.

I was forced to buy a USB dongle.
Only in this way am I able to activate the tracker!

1 Like

Can you share which one you bought and how satisfied you are?
I was thinking about the ASUS USB-BT500