Bluetooth on HassOS not working

I am running HassOS on a Raspberry PI 3B
running hassio 0.77.3
Supervisor 128
HassOS 2.2

I have this in my configuration.yaml

  - platform: bluetooth_tracker

But have no bluetooth items showing up and no known_devices.yaml
being created.

Was running ResinOS with the BCM add-on and had no problems.

Posts I have read say that nothing should be required under HassOS

What am I missing.

Any help always appreciated.

1 Like

Here is my log file
Any ideas

I added a know_devices.yaml and put my phone in it
and now it shows up but stays on away.

Log Details (ERROR)

Tue Sep 04 2018 20:15:58 GMT-0700 (PDT)

Error setting up platform bluetooth_tracker

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/bluetooth/", line 31, in discover_devices
    lookup_class=lookup_class, device_id=device_id)
_bluetooth.error: (110, 'Operation timed out')

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 183, in async_setup_platform
  File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 72, in setup_scanner
    for dev in discover_devices():
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 50, in discover_devices
  File "/usr/local/lib/python3.6/site-packages/bluetooth/", line 34, in discover_devices
    raise BluetoothError ("error communicating with local "
bluetooth.btcommon.BluetoothError: error communicating with local bluetooth adapter

Also get this in the dev info panel

Error setting up platform bluetooth_tracker

8:15 PM components/device_tracker/ (ERROR)

I am getting the same errors.
Running hassio 0.77.3
Supervisor 128
Host Stytem reads HassOS 1.10

Did it fresh download a few days ago.


1 Like

With the PI3B and a build after Aug 2018, I think you need to uninstall the BCM add-on.

I had read that in other posts and never installed the BCM Add-on
After I could not get it working, then I installed it to see if that would fix
the issue and still got the same problem, then un-installed it.

Also had read something about the the known_devices.yaml not being used anymore.

I was getting the error can not create know_devices until I created one and copied it into
my config directory.

Was that wrong should it be in the .storage now or should I not have one at all?

After that I get the sensor badge for my phone but the bluetooth tracking is not loaded.

Just ran a test. Installed:

  - platform: bluetooth_tracker

I had an existing known_devices.yaml file from my own_tracks install but it was automatically created at that time. I think you may want to delete that file you created just because maybe the permissions are wrong on it.

Turned on my bluetooth on ZTE cell phone, waited a few seconds and saw in my known_devices.yaml:

  hide_if_away: false
  mac: BT_18:68:6A:AC:E0:C0
  name: z828
  track: true

No errors in the log file.

PI3B+, 1.10, Supervisor 128, HA 0.77.3. Things working fine here.
I now suggest a hard reboot.

Just tried a clean install of latest build to see if I could get it to work
fresh out of the box.

Now I get a login page and enter info.
After that it goes to a loading data screen and never goes past
Let it run for over a hour and tried 3-4 clean installs.

Also the image I downloaded a week ago was hassos_rpi3-2.2.img
the one that is there today is hassos_rpi3-32-1.10.img
anyone know why the current one is a lower version?

After trying multiple clean installs with them hanging on the loading data.

I went back to the old install I initially had the issue with, and now bluetooth is working.

Must have been doing a complete reboot that got it working.
I was just doing a restart before.

I used ssh and touched the known_decices.yaml file. It then populated it.

What do you mean by hard reboot?

I run a Raspberry PI3 and was just doing the restart in the configuration panel
After doing a complete power down and reboot everything has been fine since.

Shutdown of HA, then from command line do a system shutdown (sync, sync, halt works), then a power toggle.

Thanks for the quick response. That’s what I thought but I was hoping you meant something else because doing a hard reboot has not fixed the Bluetooth issue for me unfortunately.

Running 0.79.3 with no issues.
Have you upgraded to latest version?

Scroll back and check the dialog about BCM. If that is not the issue, and this is a new install, at this point I can only suggest starting over with the installation.
I wish I could offer more but I have found with PI and bluetooth, it either works right out of the box or… it doesn’t work at all.

Thanks @Dixey and @wakeskate for the suggestions. I updated to the latest version and the Bluetooth presence detection seems to work now…kinda lol. The sensor itself is correct in saying that I (Jake) am home, however, the state history graph is all wrong. I have noticed this on other, non-bluetooth sensors as well. Any ideas?


I believe those items would be zone related issues. I would start by reviewing the zones, if any, that you have set up.

Did you change anything else? I have downloaded the latest RPi3 image yesterday but seeing the exact same error message you’ve got in the beginning…

Try deleting your database. I have since switched to MariaDB but I fixed the problem when I was still using SQlite by stopping the server, deleting the DB and starting back up. A new DB will be created. I hope this works for you.

Good timing! I ran in to the same problem. This fixed it for me.