Bluetooth on NUC


I’ve seen a couple of folks using NUC devices to run HA. Bought a NUC7I3BNH couple of days ago and it runs great - except Bluetooth.

I tried adding the iwlwifi firmware from Intel for the 8265 chipset into /lib/firmware, but still without success, although the module seems to get loaded:

user@srv01:~$ lsmod | grep iwl
iwlmvm                249856  0
mac80211              671744  1 iwlmvm
iwlwifi               151552  1 iwlmvm
cfg80211              589824  3 iwlmvm,iwlwifi,mac80211

Who did succeed to get BT working on a recent NUC device ? Any idea what goes wrong in my case ?


Try using bluetoothctl to make sure it’s on

That does not find devices either:

[bluetooth]# devices
No default controller available


Looks like I got it a step further. After executing

hcitool hci0 up

I found an error message related to an obviously missing piece of firmware:

[    3.584314] bluetooth hci0: Direct firmware load for intel/ibt-12-16.sfi failed with error -2

I found help here and installed the mentioned driver from the linux kernel (copied to /lib/firmware).

Now I can see the device

user@srv01:~/linux-firmware$ hcitool dev
    hci0	F8:63:3F:F9:39:E4

Also, hciconfig hci0 up worked :slight_smile:


Does this help?

Got it to work, see above.


is there any way to perform this wizardry (enable BT on NUC) on

Thank you.

How did you install I have it running in docker, and therefore I could ssh into the nuc itself to turn on bluetooth.

I have clean/direct installation of, no docker.

I have bluetooth working on nuc7i5. Try installing wpa-supplicant and bluez.

I am not sure if I can do that on (no docker).

I don’t believe you can unfortunately.

As I thought :frowning: I like but this kind of limitations are kind of annoying, aren’t they.

I installed Hassio as a vm on Virtualbox on a intel NUC creating a vm Ubuntu 64bit and the vid or vmdk image of Hassio… but Hassio is unable to find the embedded bluetooth of the NUC.
My presence detection based on bluetooth_tracker do not works.
Someone has solved the problem?

1 Like

sudo apt install bluez

Any news on that? I have issues with bluetooth on nuc. It is really unstable (device tracker). at 98% of time it does not see anyone at home. Pi was just fine with that
I am on hassio

Have you installed bluez?

No. Should I do it via hassio? Can you give more detailed instructions?

No. Bluez has to be installed on the host OS.

The post above your first one.