Bluetooth proxy doesn't detect any device

Hello everyone, I configured an esp32 bt proxy, but it doesn’t detect any bt device.
I have 3 MiFlora (HHCCJCY01HHCC) and I tried with a new one just unpacked, the bt proxy seems to doesn’t detect anything.

ESP logs:

[09:37:19][I][app:104]: Project esphome.bluetooth-proxy version 1.0
[09:37:19][C][bluetooth_proxy:051]: Bluetooth Proxy:
[09:37:19][C][bluetooth_proxy:052]:   Active: YES
[09:37:19][C][esp32_ble_tracker:796]: BLE Tracker:
[09:37:19][C][esp32_ble_tracker:797]:   Scan Duration: 300 s
[09:37:19][C][esp32_ble_tracker:798]:   Scan Interval: 1100.0 ms
[09:37:19][C][esp32_ble_tracker:799]:   Scan Window: 1100.0 ms
[09:37:19][C][esp32_ble_tracker:800]:   Scan Type: ACTIVE
[09:37:19][C][esp32_ble_tracker:801]:   Continuous Scanning: True
[09:37:41][D][esp32_ble_tracker:264]: Starting scan...

and that’s all…
I tried to disable my Xiaomi BLE + BLE passive monitor + Bluetooth integrations with a reboot, it’s the same behavior.

Anyone could help me figure this out please ?

Your scan only went for 22s.

No sorry I didn’t put much logs.
Here are logs for 20min (except api connection lines) :

INFO Reading configuration /config/esphome/esp32-bluetooth-proxy-1.yaml...
INFO Starting log output from esp32-bluetooth-proxy-1.local using esphome API
INFO Successfully connected to esp32-bluetooth-proxy-1.local
[13:30:59][I][app:102]: ESPHome version 2022.11.3 compiled on Nov 30 2022, 08:37:18
[13:30:59][I][app:104]: Project esphome.bluetooth-proxy version 1.0
[13:30:59][C][wifi:504]: WiFi:
[13:30:59][C][wifi:362]:   Local MAC: ****
[13:30:59][C][wifi:363]:   SSID: ****
[13:30:59][C][wifi:364]:   IP Address: ****
[13:30:59][C][wifi:366]:   BSSID: ****
[13:30:59][C][wifi:367]:   Hostname: 'esp32-bluetooth-proxy-1'
[13:30:59][C][wifi:369]:   Signal strength: -74 dB ▂▄▆█
[13:30:59][C][logger:293]: Logger:
[13:30:59][C][logger:294]:   Level: DEBUG
[13:30:59][C][logger:295]:   Log Baud Rate: 115200
[13:30:59][C][logger:296]:   Hardware UART: UART0
[13:30:59][C][bluetooth_proxy:051]: Bluetooth Proxy:
[13:30:59][C][bluetooth_proxy:052]:   Active: YES
[13:30:59][C][safe_mode.button:022]: Safe Mode Button 'Safe Mode Boot'
[13:30:59][C][safe_mode.button:022]:   Icon: 'mdi:restart-alert'
[13:30:59][C][esp32_ble_tracker:796]: BLE Tracker:
[13:30:59][C][esp32_ble_tracker:797]:   Scan Duration: 300 s
[13:30:59][C][esp32_ble_tracker:798]:   Scan Interval: 1100.0 ms
[13:30:59][C][esp32_ble_tracker:799]:   Scan Window: 1100.0 ms
[13:30:59][C][esp32_ble_tracker:800]:   Scan Type: ACTIVE
[13:30:59][C][esp32_ble_tracker:801]:   Continuous Scanning: True
[13:30:59][C][captive_portal:088]: Captive Portal:
[13:30:59][C][mdns:103]: mDNS:
[13:30:59][C][mdns:104]:   Hostname: esp32-bluetooth-proxy-1
[13:30:59][C][ota:093]: Over-The-Air Updates:
[13:30:59][C][ota:094]:   Address: esp32-bluetooth-proxy-1.local:3232
[13:30:59][C][api:138]: API Server:
[13:30:59][C][api:139]:   Address: esp32-bluetooth-proxy-1.local:6053
[13:30:59][C][api:143]:   Using noise encryption: NO
[13:30:59][C][improv_serial:032]: Improv Serial:
[13:32:41][D][esp32_ble_tracker:264]: Starting scan...
[13:37:41][D][esp32_ble_tracker:264]: Starting scan...
[13:42:41][D][esp32_ble_tracker:264]: Starting scan...
[13:47:41][D][esp32_ble_tracker:264]: Starting scan...
1 Like

Check via HA logging

Hi,

I have the same issue. ESPHome Wroom 32, flashed with the BT Proxy, scanning witthout results. I’ve had no previous BT devices configured in HA. Any help?

Thank you!

1 Like

Have you figured out the reason for that? I’m having the same issue on my end.

I was testing bt proxy with ATC Custom firmware (LYWSD03MMC), which seems to not be compatible.
Then I tried with MiFlora and it worked without changing yaml ESPHome config.

There is no real logging with bt proxy yet, so be sure to use a compatible bt device.
You can use this config template to make it working : bluetooth-proxies/esp32-generic.yaml at b75bed9b0d832b0c80d32870ba220a3298123484 · esphome/bluetooth-proxies · GitHub

Good luck

HI all…My BT Proxy first didnt find any devices…after a lot of rebooting and stuff i atleast got it to recognize a Switchtbot Curtain…

But it still wont connect… I get this (error) message:

[14:10:30][D][esp32_ble_tracker:327]: Starting scan…
[14:13:43][I][bluetooth_proxy:254]: [0] [EE:3B:05:F3:B3:FB] Connecting v3 without cache
[14:13:43][D][esp32_ble_tracker:216]: Pausing scan to make connection…
[14:13:43][I][esp32_ble_client:064]: [0] [EE:3B:05:F3:B3:FB] 0x01 Attempting BLE connection
[14:13:59][D][esp-idf:000]: W (778633) BT_HCI: hcif disc complete: hdl 0x0, rsn 0x3e

[14:14:04][I][esp32_ble_client:078]: [0] [EE:3B:05:F3:B3:FB] Disconnecting.

Not sure what this means though. Can anybody tell me?

I know this is old but i am having the same problem with the same firmware. Do you know how to put the stock firmware back on?

If you just select BT Home (can’t remember the name of the setting) when flashing the Miflora, it will be discovered by HA via BT Proxy.