Home Assistant Community

Bosch ISW-ZPR1-WP13

#1

I purchased a couple of these Motion Sensors hoping they would work
with Hassio but have had no luck.

It seams like someone may be working on it, because entity_registry
finds it and creats 2 sensors for motion and temp but does not work.

Is anyone working this or is it a dead end and never going to work.

You can’t beat the price and they are built well.
Would be great to get them working.
It’s times like this I wish I had more coding knowledge.

Thanks for any input.

0 Likes

#2

The answers aren’t going to be forthcoming.

I’ve had a few of these for 6 months waiting for someone (anyone…) to answer this exact question. I also assumed they would work since they are “zigbee” devices.

There have been several threads about this and a couple of feature requests that I know of (maybe more). No matter how many people ask the question we get ignored.

0 Likes

#3

Any chance whoever got the Visonic MCT-340E working could take
a look at this and let everyone know if it’s a lost cause, or if maybe
they can get them to work.

Any info would be greatly appreciated.

If anyone has info to get me started in the right direction on how to
test or work on something like this I would be glad to help, just
don’t have much advanced coding experience.

0 Likes

#4

I’ve been holding on to one of these motion sensors for a while as well. At this point I’ve just accepted the fact that I should look elsewhere and sell off the Bosch to someone with Smartthings that can use it.

I just ordered a bunch of Xiaomi motion sensors and they’re great. I picked them up for something like $9 a piece and they’re smaller than a D battery. They also measure illumination readings. I think it’s possible to connect them with a zigbee stick, but for ease of use I just purchased a Xiaomi hub for like $25.

0 Likes

#5

Noticed these are now displayed in the ZHA Panel
with a listing for a quirk and it says
Quirk applied: false
Quirk: zigpy.device.Device

Anyone know how to apply the quirk and it it gets these working.

0 Likes

#6

What do you mean by this? Where is that?

0 Likes

#7

In Configuration side panel
then ZHA configuration option
then pick the node and it shows the sensors etc for that node.

0 Likes

#8

Oh, ok. So you already had one paired and it showed up there?

Have you had it paired very long?

Every time I tried to pair one in the past it would pair ok at first but then drop off the network after a little while. But it would never show any motion detection.

0 Likes

#9

Yes that is the same problem I have always had with these.
Just hoping that the quirk feature might be a fix, and trying to
figure out how to apply it.

0 Likes

#10

there might be some “good” news on this but it will require you to make another small investment in different hardware.

I was trying to get these supported by Zigbee2MQTT and working with the developer to get it working. But we weren’t having any luck at all. Then another member sent him a device and he now reports that it is supported. I haven’t tried it yet but the thread is here:

and here is the link to zigbee2mqtt:

and the related HA forum thread:

Hopefully these will be supported by the native ZHA component soon but if not, at least there is an alternative now.

0 Likes

#11

I am using the HUSBZB-1
Have seen posts about Zigbee2mqtt but don’t understand how that
would fix the issue.

Can I use Zigbee2mqtt with the HUSBZB-1?

0 Likes

#12

I got the visionics working. How can I help?

0 Likes

#13

I have 4 Visonics and they all work great now with temp
Thanks…

The motion sensor shows up it just won’t stay connected.
Some posts said their was a way to get it to work but I just keep testing
with each update and still not having any luck.

Now that the ZHA shows what is connected and I can see that it has a quirk
I thought that may get them working, but don’t know how to apply the quirk.

Quirk applied: false
Quirk: zigpy.device.Device

Hope that explains what I’m asking.

0 Likes

#14

it won’t fix the issue using your zigbee stick and ZHA. You would need to buy a different zigbee stick. that’s what i said in that post.

No.

you didn’t look at any of those links I posted above did you?

0 Likes

#15

I did read your posts, just was not clear on it.
My question was about the quirk feature in the ZHA
not looking to replace my hardware stick for 1 sensor.

0 Likes

#16

Update.
Updated to 0.91.3
Removed Bosch ISW-ZPR1-WP13 in the ZHA configuration panel
Reset Bosch ISW-ZPR1-WP13 and then did the new devices in configuration panel
and now the Bosch ISW-ZPR1-WP13 is working so far for the last 2 days.
Has both motion sensor and temp sensor working.

So nice when something starts working that you thought was a lost cause.

0 Likes