"Brains" of Prime Wire smart outlets?

I was tempted to pick up a 3 pack of smart outlets by Prime at Costco. The product information is pretty thin, but I am wondering if I could get them to work with HA? Has anyone opened one up? Are they built with the ESP8266 and so flashable with Tasmota?

Can’t say for sure, but those outlets look exactly like the ones I just bought branded Globe, which were just Tuya devices. Was able to use Tuya-convert to re-flash them. From the link you posted it looks like the Prime are the same product, and thus Tuya.

Have you bought them and been able to flash them ? I’ve been struggling to do the same but maybe there is something i’m doing wrong

anyone got them working with Tuya-Convert ?

Looking for the same information…
Anyone was able to flash them ?

Edit: i was able to flash them

I’ve been meaning to update. Sorry for the delay. Yes, I was able to flash them without problems. I used mainly this tutorial : https://www.youtube.com/watch?v=dyUyewiKpRA. Only a few things have changed in the process since : It is now even simpler. I was using a Raspberry PI 3B+ I think. Thanks AaronCake, your reply was all I needed. I managed to get hold of 3 packs, so 9 in total before they ran out at the local Costco. One was DOA (odd little clicking & buzzing emanating from the unit when powered), but I can’t return as it was a .97 item so no more coming sadly.

I did not use rasbery but any linux with wifi capable to broadcast could do.

was you able manage the light on the device ?

ok i was able to finish
but one of them was DOA , returning all tomorrow and getting an other set :frowning: sadly will have to redo all the setting.

I noticed that the light on the device didn’t work with the initial firmware image (loaded by tuya-convert). However, once it was up and I upgraded to the full tasmota image and applied the correct template, the light is working. Out of curiosity, where are you getting yours?

Yes , Ligth is working fine now.
I am getting them from cotsco in north of Montreal, Boisbriand.
they have a good stock.
19$ Cdn for the 3 pack i think that’s a good price.
They do not have Energy Monitoring but at this price you cannot expect much

what you mean by " I can’t return as it was a .97 item so no more coming sadly"
I am planning return mine tomorrow.

So to close the Loop Here,
I return my pack of 3 Plugs to Costco (with no issue) because one was DOA…
And picked up 2 Packs (Since costco did mention to me these migth never been restock)

i Also get the gentleman to provide me a list of Cotsco with in my area who still carry them and how many they still have in stock.

I quickly flash them to make sure no issue and all went fine.
i put some in immediate use and will play with one (test, found out the other GPIO usage etc…)


Looks like a bunch of the prime devices are listed in the official Tasmota compatibility database too. I have a two pack of the outdoor dual plugs on the way. About $8/outlet ($16 / dual outlet device) CAD before tax on their website. Should be even cheaper locally if available. Looking forward to flashing them.

Edit: Just noticed these outlets are serial flash not OTA which I have not done yet and don’t have the gear for. Bummer. Has anyone attempted an OTA flash with these?

1 Like

Has anyone set these up with ESPHome?

I just bought these and tried to OTA with tuya-convert. It didn’t work. I think the device has the new firmware, outlined in this issue: https://github.com/ct-Open-Source/tuya-convert/issues/483

It is super easy to open and has nice onboard pins for serial flashing. I usually do OTA, but had to try serial flashing a MagicHome LED strip controller. Using a cheap USB UART device from Amazon and Tasmotizer it was surprisingly easy. The hardest part was soldering wires to the pads for TX/RX/3.3V/GDN. But this device has them all easily laid out. You could probably get away without soldering…just use something like sticky-tack to hold the four/five pins in place for 5 minutes. If you’re only doing two devices it might not be too much of a pain.

instead of hacking the firmware, is there a way to directly get them imported into HA via addon, integration or something?

I suppose you could try the Tuya integration (assuming this device uses the Tuya cloud).

Just tried, it works like a charm. Surprising that the Prime App is just a plain rebrand, and what’s great is that the Tuya App doesn’t try to block other vendors devices to be imported into their system.

Tuya offers manufacturers a turn-key service. You can manufacture devices based on Tuya’s design reference, equipped with Tuya’s firmware that connects to Tuya’s cloud service, and accessible via a re-branded version of Tuya’s app.

There are many, many manufacturers who, wishing to enter the home automation market with very little R&D expenditure, take advantage of Tuya’s turn-key offering.

Hi. I have attempted to flash "Prime Smart Outlet Outdoor Plug (CCWFIO232PK) dated 8/20 with frustrating unsuccess with serial port. But can not get it into flashing mode. The unit has 7 pin holes which I have as 1-blank, 2-GND, 3-TX, 4-RX, 5-33V, 6-i00, 7-R?T which I assume are correct. I am using DSD Tech SH-U09C5 FTDI FT232RL which I have tested to TX and RX. It also supplies 3.3V to the PCB. The serial port is configured with baud 9600, Data bit 8, Parity none, Stop bits 1, Flow control as none.
I followed the instruction on https://tasmota.github.io/docs/Getting-Started/#after-configuration. I checked all Dupont cable connections but, nothing doing. What am I missing?

PS. Corrected header locations.

I followed this example for wiring it (it worked previously for a MagicHome). Magichome devices work PERFECT with homeassistant (reflash this code with ESPHOME)

I had i00 set to ground, which from my understanding puts the ESP into programming mode on power on.
I used Tasmotizer to flash it: https://github.com/tasmota/tasmotizer it was very straightforward and just magically worked.

I do remember that the labels for the header seemed to be off. The first label on the left, either GND or 33V, was shifted. It looked like the label applied to the second header from the left, when it actually applied to the header on the far left. I used a multimeter to check connectivity from another labelled pin on the board to confirm I had the right header. The other labels seemed to line up correctly.

Thanks for the assistance, The connections look correct by following the circuit board and matching it to the esp8285 chip diagram. I tried both outlet units with the same inability to get into flashing mode or get a connection. Maybe forced to use these with the Tuya integration.