Broadlink IR Climate Component


Hopefully one of you can help me with the following issue

At home i have a KNX system and i am using Panasonic AC units to heat the rooms also i can change all the settings over this climate component in Home assistant

Now i want to make it possible to use the knx buttons to change the temperature settings, for that i can configure the KNX climate component in home assistant but i dont know how i can synchronise the values of both components.


@Vassilis great custom component that I’ve been using for awhile now. I submitted a new pull request to add an optional humidity sensor to the broadlink climate component.

This will enable users to associate a humidity sensor and allow services such as google assistant to report the humidity state as part of the climate device.


Hi there @smile. Did you try the Toshiba INI file from this project’s GitHub repo? Works fine for my split system.


unfortunately i haven’t Broadlink. i will buy soon.


I am not sure why, but I can’t load this component. I have a broadlink switch all set up and I’ve placed the file (along with the .ini file) in my config\custom_components folder.

I have even tried putting it in config\custom_components\climate, to no avail.

I have other custom components working fine, but all I get is:

- Platform not found: climate.broadlink

And no other warning messages in the log. Any ideas?


the right file should definitly go under custom_components\climate.
The ini file should go where is specified in the configuration.yaml:
ircodes_ini: 'broadlink_climate_codes/panasonic_sogg.ini'


Yep, deleted the “wrong” one and same result.

No idea why it doesn’t load (where another custom component does).

Edit: I was running 0.83 and it didn’t work - updated to 0.86 and it does now!


yeah i do this already.

on change in state of climate then wait 5s then check to see if the door sensor has changed, if not get the expected state and send the same command.


This is exactly what I am trying to do. Would you share with me your config/automation script for this please?


@kiwijunglist, @calpy I have a few questions for you:

  1. Why is this necessary, do your codes for turning on not work every time? Maybe you should try relearning them, because that just doesn’t sound right.
    maybe the code is valid, but AC needs the code to be sent in bursts (repeated multiple times in short period) to be sure to catch it. You can modify each command code to send bursts like this:
    Take the code in base64 format, let’s say Mitsubishi ‘off’ command:


Go to this site and paste your code in the left text area
In the right text area, you will se hex format of the same string. It starts with 26 (that is Broadlink’s code for IR), and the next byte is usually 00. That is Broadlink’s repetition setting, default is 00 (no repetitions). If you change this number to 04, your command will be sent 5 times without a pause between them, and you will notice base64 string in the left text area now looks like this:


  1. Door sensor, apart from visual factor, takes away your ability to natively control your AC through Google Assistant, does it not? Instead of saying “Hey Google, turn off AC”, you have to tell it "Hey Goole, start , would it not be better just to ensure your codes work every time?


This is brilliant! Will try asap

  1. Yes sometimes it does not catch the command and need to say it twice or more times.
  2. You are right, I thought to use an automation like IF command sent AND after 5sec sensor is still off THEN repeat.

If your suggestion works, sensor is still useful to tell HA if AC goes from off to on via physical remote, but indeed without information about temperature, modes acc.


Using a door sensor is a simple way for automations to ensure it is in proper power state, but for voice commands, it doesn’t feel natural because you have to trigger scripts instead off native thermostat controls. Personally, I find it unappealing visually so I would rather use power consumption meter and hide it behind AC.

If your AC supports discreet codes (you can distinguish commands for power off/power on), I would rather set the second byte to a value of FF. That makes Broadlink repeat the code maximum amount of times (256) and that should be enough to get rid of the door sensor.

  1. It’s pretty infrequent. It might happen if someone was walking very close to the IR blaster and blocked it. Thanks for that info though. I’m using the default codes. It might also happen if there was a network error, so it just enables an element of error checking.

  2. It doesn’t interfere with Google controlling the AC. It allows me to use my mom smart remote as well as the error checking.


If you have the new codes, it’s important for you to pass them to me, because my split of cold air only, Mitsubishi, does not work with the downloaded ones.


Sure I’ll PM to you, if they work tell me and will get them added to the IR code list


Has anyone figured out how to get this discovered in Alexa correctly? I’ve managed to get the climate components discovered, and I can increase and decrease temperature, but I can’t change the operation mode. My Nest thermostats work without a problem, but everything that I have with Broadlink cant be toggled off or change operation mode.

I’ve managed to create scripts and have them discovered in Alexa to get around this for now but it is a real pain and doesn’t always work correctly.


Thank you so much
This will prove it and I will comment if it works.




I had wrote new fujiko.ini for my clima, I share this code for help someone



Hi, I have a broadlink rm3 mini and akay air conditioner. I cloned akai remote and I created ini file all is good but fam mode no. If I go in fan mode and I set low hight medium or auto air conditioner doesn’t go. If I sent one of 4 learned all is OK but under climate doesn’t go. Why how can I solve?