Broadlink Manager - Nicer way to Learn and Send IR/RF commands

dont read RF for me.

Does this work with the new 2018 RM Pro+ (plus) model? I’m able to learn RF in the e-control app but not with your broadlink manager.

It didn’t work for me either.

Hi @Tomer_Klein

just downloaded from your link, but on Win 10 when I launch the “Broadlink Manager.exe” I get an error message that says that’s impossible to execute this app on my PC.

I tried also setting compatibilities with Windows 7 or 8, but with no result.

What can I check?


Just wanted to say that this is awesome. Thanks for developing it :slight_smile:

This is great!
Only one request - would it be possible to send commands via the command line? That would make this much more useful!

Right click the file and choose unblock at the right bottom from the general tab.

This is awesome! Thanks for your work! For those who get stucked at hold the button down: i think this is because they didnt hold the button long enough or fast enough and then the process is fails. So if you get stucked try this: 1. cancel the learning mode. 2. Select Lern rf frequency 3. Press and hold the button untill you see “Press the rf button multiple times with a pause between them, so do it. And then enter a name for that code! The first time i get stucked at hold the button down, then i did it again faster and it worked!!

1 Like

yes… there is a way using a oneclick app that can run in command line with parameter.
hoping to release it in few days.

Man, I’m still stuck on the RF learning. Has anyone timed how long you have to hold the button before you get to step 2? I’ve held it for 3 min. It starts to hurt my poor little thumb…

Superb work on this!

The IR part is seamless and saves a bunch of time. Would really love to get the RF part working that good.

Hi @sendorm

I’ve checked, but still same issue. :open_mouth:
Really strange.

I am also having a problem here because my remote automatically stops broadcasting after just 5 seconds. I suppose o help extend battery life. Regardless, this apparently isn’t enough time for Broadlink Manager to pick it up.

maybe that’s what mine is doing too. I tried with an RF door sensor too, but it was clear it wasn’t broadcasting the signal long enough. I’m still looking for the RF solution…

Hello Dr., nice to see you here!

I wonder why you need to learn the code from a RF door sensor with the RM PRO? Sounds like another very cool project of yours.

I am following this thread because I might use this solution to learn a bunch of new RF codes soon…


What is the distance between the RF remote and your broadlink?
broadlink RF reciver is very weak, you should hold the remote on top of your broadlink.

It was close but I’ll try again closer. I wonder if the problem is the duration. I tried with a remote with a button but I don’t know how long it will broadcast the signal. I tried with a door sensor and I know it only broadcasts for a second then stops.

I just gave this a try. Had the remote laying on top of the RM Pro as I held down the button on the remote. No joy. I, like @DrZzs, think this may be related to how short the remote broadcasts. Might not be long enough for the Broadlink to catch it.

I got out my only android device and tried the older broadlink app (e-control). It was able to learn the codes. Now I need to see if I can somehow see those codes and use them in HA…

I did it!
I followed these instructions from Sam:
Android device required
1. Install Broadlink e-control app from Play store
2. Learn your remotes as per normal instructions using e-control.
3. Tap the burger settings and tap ‘Share’. Tap 'Share to other phones in WLAN. Tap Cancel.
4. Install RM Plugin Lite from Play Store
5. Tap on Device List to import Broadlink device config that was previously shared.
6. Enable HTTP bridge
7. Navigate to http://androidipaddress:9876/ 11
8. Find Code List and click on the link.
9. Find the code(s) you require.
10. Use a Hex to base64 converter to encode your codes for HA ( 21)

It’s a level 9 pain in the rumpus, but eventually you get a code you can use in HA. I’ll do this once for the video explaining how to do it but after that I’m back to the Tasmotized Sonoff RF Bridge for all my RF needs.


Thank you!! The only thing I would add to this is that when I was learning the codes, I had to select Swap Frequency instead of Learn. If I just tapped Learn, it would time out. When I selected Swap Frequency, I would long press it to learn the new frequency setting and then tap it to learn the code.