Broadlink Manager - Nicer way to Learn and Send IR/RF commands

Would love to give this a try, but am windows 7 on my main pc, and osx on my laptop, tried to install windows 10 in paralles on osx, but couldn’t get this to work, but didn’t have much time to play around with it, will try again tomorrow. But if there is any way to run it on any other platform, that would be amazing.

I have the exact same problem. So far, I have only been able to learn RF codes via the app.

Btw: I love this program; it is really handy :smiley:


same for me. Doesn’t work for RF Codes right now, only getting those via the app :confused:


@Cee Hi,
after a few retrys i succeeded to run the app correctly on windows 7.
i have created a new setup and you can download it from here:


Amazing, thank you very much. Just downloaded it and gave it a quick try with my RM Mini 3 and it seems to be working perfectly for IR codes. This will make life so much easier.

I did partition my Macbook this morning with a trial of windows 10, just to run this, so I had also got it running on there, but as above, actually having it on my main PC will speed things up so much :+1:

Any one succes with RF code? Can you confirm

RF Frequency Learning mode is enabled.
RF Frequency Scan[1/2]
[Hold the button down!]


Work well for me
1st hold for long
2nd short and repeat

Hi, i have 2 rm mini and 1 rm pro but only one rm mini shows up in the program!
any ideas.


I have the same issue with 1 RM Mini and 1 RM Pro

dont read RF for me.

Does this work with the new 2018 RM Pro+ (plus) model? I’m able to learn RF in the e-control app but not with your broadlink manager.

It didn’t work for me either.

Hi @Tomer_Klein

just downloaded from your link, but on Win 10 when I launch the “Broadlink Manager.exe” I get an error message that says that’s impossible to execute this app on my PC.

I tried also setting compatibilities with Windows 7 or 8, but with no result.

What can I check?


Just wanted to say that this is awesome. Thanks for developing it :slight_smile:

This is great!
Only one request - would it be possible to send commands via the command line? That would make this much more useful!

Right click the file and choose unblock at the right bottom from the general tab.

This is awesome! Thanks for your work! For those who get stucked at hold the button down: i think this is because they didnt hold the button long enough or fast enough and then the process is fails. So if you get stucked try this: 1. cancel the learning mode. 2. Select Lern rf frequency 3. Press and hold the button untill you see “Press the rf button multiple times with a pause between them, so do it. And then enter a name for that code! The first time i get stucked at hold the button down, then i did it again faster and it worked!!

1 Like

yes… there is a way using a oneclick app that can run in command line with parameter.
hoping to release it in few days.

Man, I’m still stuck on the RF learning. Has anyone timed how long you have to hold the button before you get to step 2? I’ve held it for 3 min. It starts to hurt my poor little thumb…

Superb work on this!

The IR part is seamless and saves a bunch of time. Would really love to get the RF part working that good.

Hi @sendorm

I’ve checked, but still same issue. :open_mouth:
Really strange.