Broadlink Manager - Nicer way to Learn and Send IR/RF commands

Hi @kitus,
i’m aware of it and trying to fix it.
Hopefuly will update till the weekend.


Thanks a million @Tomer_Klein! please let me know if there is anything I can do to help. Just tried it again now and learning IR codes works impressively well :slight_smile:

I too can’t seem to have my RM Pro+ learn new codes using the method outlined in the RM switch component section in HA

How to obtain IR/RF packets?
Choose Call Service from the Developer Tools. Choose the service switch.broadlink_learn_command from the list of Available services: and hit CALL SERVICE. Press the button on your remote with in 20 seconds. The packet will be printed as a persistent notification in the States page of the web interface.

This does not work either… that’s why I suggested the RM Pro+ may be crippled by design.


Basicley every broadlink device as a device type :
0x2712: //“RM2”;
0x2737: //“RM Mini”;
0x273d: //“RM Pro Phicomm”;
0x2783: //“RM2 Home Plus”;
0x277c: //“RM2 Home Plus GDT”;
0x272a: //“RM2 Pro Plus”;
0x2787: //“RM2 Pro Plus2”;
0x279d: //“RM2 Pro Plus3”;
0x27a9: //“RM2 Pro Plus_300”;
0x278b: //“RM2 Pro Plus BL”;
0x2797: //“RM2 Pro Plus HYC”;
0x27a1: //“RM2 Pro Plus R1”;
0x27a6: //“RM2 Pro PP”;
0x278f: //“RM Mini Shate”;

I’m Guessing that your device is not listed here (and i was unable to find it over the web like i did with the others). when i’ll find it i’ll add it to my code and then it sould work fine.

Good catch!!! Is there anything I can do to speed this up?

@Tomer_Klein, isn’t that one my model?

I’m trying to use your software on a PC without a wireless network card and I cannot see my RM Mini 3.
I have a pair of them. Their IP address are already configured and I can ping them.
I tried to add them manually using the IP and MAC address but the program still doesn’t find them.

Any suggestions?



Yes, like I said: I believe that’s a false-positive. You can create your own package by following the instructions. You can download everything from the original source and compile yourself. I’ve done it on my personal PC, I can assure it it clean :slight_smile:

Too bad I am not a programmer, would love to help and create a Hassio Addon to use with all Broadlink remotes. I believe they are the best alternative to use with IR and RF.


is there anyway to work this broadlink manager to be used on Ubuntu 18.04.
Please guide

You save my day mate!
I have a RM2 Pro Plus_300 and like many other user here I couldn’t get RF codes with Hassio call-service or Broadlink Manager.
Your procedure is a bit tricky, but it works perfectly!

I hope that a simpler method will be found in the future, let me know any update.

I’m getting nuts with this. I just can’t get e-control to work with my device. Only IHC works and i can’t follow that procedure. Did you do anything special with the device?

1 Like

@Tomer_Klein I believe my model is indeed in the list you posted earlier. Am I missing something?

Hi kitus.
No, nothing special :man_shrugging:

Some more info.
The Broadlink has a static IP and I use e-control without any log-in. When I started the app the the first time (with the phone in the same wireless network), it founds immediately the RM2 Pro Plus. That’s all .

Hi, I have being using two RM2 Pros Plus devices in different rooms for a while now via RM Bridge on a tablet so was delighted when I stumbled across this little gem so that I can control directly from my PC without the middle man. Once I had disabled the Avast Web shield I was able to get somewhere - but here’s my problem …

Whenever I do a scan it will only ever detect one of my devices - NEVER both. I can then learn and send IR codes (haven’t tried RF yet) without issue with that device. The only way to detect (and use) the other device is to cyclically close the app / reopen / scan until it has randomly detected the one I’m interested in. I guess that even if it did detect both - how would I distinguish between them in the drop down box if they are both called the same thing?

Even more frustrating is that if I try and use the OneClick utility (my ultimate goal) it is random as to which one it tries to send to and hence adhoc as to whether or not it actually delivers the desired result.

Is there someway in which I can force selection of the correct device (in the Manager and OneClick)?

Please help as this is so close to being exactly what I’ve been looking for for quite a while. Cheers

Hi, i would love to try this method, finally i could get a old windows 7 notebook, but when choose rescan wifi, it can’t find my RM pro, it needs to be in pair mode? I would like to know if doing that, will reset every remote i have learned in my IHC app, dois anyone knows?


so how come this program wont work in windows 10?

is there a fix to not be stuck on step 1 of 2?

will a windows 7 machine work? if so I can set up a w7 vm

Please Help

I have same problem , no way to learn RF

looks like fake RF

Just want to say thanks for this program. Worked well for me (even on windows 10). It worked for RF when home assistant wouldn’t show me any codes.

Have you try to put your broadlink into AP Mode?
Do you have Wireless Adaptor on your computer?

@Tomer_Klein I’m able to add my device to network but when I try to scan nothing happens, just a message “Looking for devices…” and nothing more.

My Devices.json:

    "MacAddress": "78:0F:77:4F:60:27",
    "IpAddress": "",
    "Prefix": ""

My PC is in the same network as the broadlink, I can ping him. I already tried to edit the file and insert the exact IP but still nothing has changed.

I’m using Windows 10 Pro - Version 1803