Broadlink Manager - Nicer way to Learn and Send IR/RF commands

Hello guys!

Reading through the posts here, I’ve found a great Python Script that converts the codes learned from the E-Control app using the mobile, something that I found very useful and easy to do. The script discovers all learned codes and creates an YAML file with everything converted and ready to use on HA.

Here is a video showing how it works:

Here is the post: Broadlink e-control to yaml

I’ve compiled an .exe file so anyone can run the script without much code or even installing Python.

Here is the program:!7N91xabJ!NXVBw6tSe8RIoCVaULGB5rJ5uUB8nsWTR4nJPgrBLC8

VirusTotal results (just for peace of mind, you can create your own if you want :slight_smile:):

You just need to copy the files jsonSubIr, jsonButton and jsonIrCode from the Android phone, located on “/broadlink/newremote/SharedData/”.

Used this method to compile the program:

I hope it helps!


Hello guys,

I don’t have Android, and I need to scan RF codes !!

I tried the windows 10 and windows 7 app and didn’t worked !! :frowning:

I can scan IR codes but no RF codes :confused:

I get the “RF Frequency SCAN (1/2)
(hold the button down”)

I hold it for 10, 15 seconds and nothing :frowning: I tried several times!! feelsbad

can someone help me out?


Maybe you can use an Android Emulator for Windows, something like this:

Hope it helps.

1 Like

It actually worked !!!

Muito Obrigado !! :smiley:

1 Like

Great tool @Tomer_Klein. Thanks!

The program isn’t working for me. Win 10. When I originally downloaded it, I was able to capture lots of IR codes from several different remotes and save them in individual files. Not sure what happened but now, the program closes after I save one IR code. But it isn’t saved, I am back to square one trying to capture codes. Also, I was never able to save the devices (3 RM mini broadlinks). It can’t find the network when scan is clicked. And I can’t manually add a device by entering the mac address and IP address. So basically, the program is broken. I have uninstalled and re-downloaded the program and reinstalled it three times, but still no go.

I like the way it was working, and would like to be able to use it again.


I have been trying to use the app to learn RF commands but I cannot get the app configured, all I get on the Device Pairing is:

I am using Windows 10, do I need to install and pre-requisites?

I also cannot add a device manually using MAC, IP.

Struggling getting the app to work. My RM Pro is already connected to wifi. When i click scan, it says looking for devices, and nothing happens. I added the device manually through it’s ip address but doesn’t work either. any advice?

the broadcom works fine with HA.

Many thanks!

I Had a the same issue, disabeled all firewals and virus shield and it workwd 100%.

I having the same issue.
Domain firewall off
Private network off
Public network off

still can’t get this to work.

Dont forget virus shields aswell

Hi @fayraz,
in order to Pair a new device using my software you need to enter your broadlink device into AP Mode.
in order to do that first press the reset button until the blue led blinks fast.
then press the button once again untill the blue led blinks slower.

you also must have Wifi adapter.
fater doing all the above press rescan and then you’ll see network calld BroadlinkProv and from there continue with the paring.

hello … how to make new ini file for new remote ? how to make the haet and cool for ac

1 Like

Hi guys,
I am new to this forum so forgive me for asking something that has previously been responded to.
Is there a tutorial on how to get a RM PRO to teach a learned code onto a new remote?

Thanks for this app it has worked successfully to learn my RF codes when HASS could not! I’ve submitted a change to the component page for instructions to use this app

1 Like

same here I think!! neither this app nor by doing it off home assistant seems to work with this model… can somebody confirm this model is behaving this way too? I only suspect it… strongly suspect it

I too have that very model and it won’t work with this. This is just too bad! :frowning:
@Tomer_Klein any chance you could see why the RM Pro+ won’t be able to learn codes using your app? It feels as if this device was a bit crippled by Broadlink… :frowning:

Any workaround would be extremely appreciated.


Same behavior over here with the rm pro+ product. It works well with the app but it just won’t report any code using this method :frowning:

I strongly support that suggestion. It would come in handy!

hi there

seen this? one file looks highly suspicious and the other one has a confirmed trojan? am I missing something?