Broadlink RM Mini 3 periodically losing connection

Hello everybody,
recently i’ve got some serious problems with my Broadlink RM Mini 3.

They are periodically losing connection to the infrastructure. I first thought this might be a hardware related issue and replaced the old one with a factory new one, but same problem.


Having a look at the above results from a ping device there seems to be a scheme, 6 minutes disconnected, 2 minutes connected…

I’ve updated the firmware to the newest available, but same issue. Is anyone elses experiencing this or is able to give some suggestion to fix this?

Whats the wireless coverage like? Does the connectivity improve if you move it closer to the access point?

In the current testing setup around 1m.
The strange thing is, this setup worked for months but then, literally overnight, this strange behaviour started.

Do you see the same 6 off/2 on with the units LED? I think blinking means connecting?

I’m having the same problem.
Any progress?

The guys over here Broadlink RM Mini3 - keeps disconnecting from wifi? figured out that it could be a router-related problem.
I’m currently using a FritzBox 7490 and the problem is still there in the newest beta-firmware.

I will check this out soon with a UniFi Access Point, maybe there were some changes in the firmware which are causing these problems.

I am sure in my case it was a hardware defect with Asus router, and the broadlink connectivity was one of many other symptoms of that failure.
Broadlinks now remain connected for 100 hours+ on replacement.

I have the same problem with a RM Mini 3 using a Unifi UAP-AC-LR at 1-2m from it.
Connection history in Unifi Controller shows a reliable pattern of 2m/5m connection time between re-connections.

The device is on a VLAN with no internet access. I will try to connect it to my main network to see if it changes something.

It seems like removing internet access to the RM mini 3 makes it angry !

I connected it to the network with internet access and no more disconnects…

You were absolutely right about the missing internet connection. I can’t remember why and when, but I had also disallowed the RM Mini 3 to connect to the internet. After deleting the rule the disconnects are gone…

In my opinion a absolute outrageous behaviour, the device seems to check if its able to connect to somewhere, what about this destination will not be reachable anytime in the future, then this can be thrown to the trash can.


Well even if it’s not able to communicate, the device still works. It is just spamming the logs with re connection each 2 or 5 minutes constantly.

For the information, here are the 2 IPs it’s trying to reach:


Both seems to be AWS servers.

I would be interested in seeing what kind of data is sent, but my wireshark skills are not up to the task :slight_smile:

1 Like

For me my RM Mini 3 DOES have internet connection, however every 60 minutes it restarts. Any idea why this would be?

I have exactly the same problem… RM Mini has access to internet but still roughly every 60 min disconnects and reconnects

I’ve the same issue and I also have Unifi APs. I’ve 3 units of rm mini and all 3 loses the connection at the same time.

@Drax, What version do you have on your APs?

@TheDanShepherd, Do also have Unifi ?

I have Dream Machine with version
and UAP-NanoHD

@Drax, thanks. I’ve 2 units UAP-AC-HD with version and controller

I’ve discover that the time between disconnections depends on “Enable GTK rekeying every” value. I changed from 3600s (1hr) to 1800s and you can see the effect:

Also, downsizing to 1800, other devices began to disconnect, so I’ll make some tests to find the correct value.


I can confirm that this issue, at least on my platform, is related to Unifi configuration:

I’ve made a lot of changes and now solved rm mini problems, but introduced drops on other devices.

I’ll come back with my config once it works with all my devices.

Same issue here any update on ur configuration

If your using a unifi device to provide WiFi set the setting from PMF from optional to disabled. A recent update has added PMF support to some unifi products that didn’t have it. My rm mini was reconnecting every 51 mins till I disabled PMF.


Nice tip @James_Will_i_am_Will - I Gotta Feeling that tonight’s gonna be a good night after making this change. I also just disabled GTK Rekeying altogether - might re-enable and set to 86400 (was at 3600) but figured I’ll just keep an eye on things for a few days first. Curious if anyone has input on disabling GTK - either ‘OH NO YOU GONNA B HACKD’ or ‘meh no risk for a family network in the sleepy burbs.’

edit aaand, now that damn song is stuck in my head. thanks @James_Will_i_am_Will and sorry everyone else. :smile: