Broadlink RM-PRO and A1 sensor

ok,i try to fix this problem first…

same here

pip install is not working … but…

pip3 install …works

what meaning is following files and put them in the same folder as this script?

For those of you having problems with time out errors; you should tru this fix:

Thanks - I put the changes you suggested a couple of days ago in and they also worked. Have modified the file to the latest change. Have not seen one error over the past 2-3 days.

On a different issue but similar… I noticed some suggested changes for the orivbo switches which I made earlier today - so far so go no errors.

RM Pro has two learning methods. Learn, and Frequency Sweap (sic). In my effort to get my Livolo switches to work with RM Pro (overview and findings here) , I contacted Broadlink, and from what I understood in the probably google translated response, for RF codes Frequency Sweep is the learning mode that works (or at least works better). Currently it’s being done through e-Control.

The process is that once you enter Frequency Sweep mode, you have to keep the remote button pressed until RM Pro gets a good reading of the signal. Then it asks you re-learn the code in the simple Learn way, where you just push the remote button once.

I’m no expert on this, but I suspect that through the frequency sweep, RM Pro gathers enough data and signal loops, and on the second learn, it pinpoints exactly the portion in the collected data that needs to be duplicated.

In my case, unfortunately the livolo remotes (at least the ones that I have), will only send the RF signal once (or at least for less time than RM Pro’s frequency sweep requires to learn), even if I keep the buttons pressed, but I’m looking into other remotes atm.

Maybe it would be a good idea to emulate this in the library and integrate this two step process in HA

I’ve been trying to access the temperature sensor in the RM Pro and generally it seems to work. However, on a 8-10 hourly basis there will be one erroneous temperature reading of ~250C. That really screws up the graphing of temps.

Is there any way to stop this, or at least reject any temp measurement where the occupants would be inside an oven?

Shouldn’t Broadlink come under a remote instead of a switch in HA, similar to the Harmony?

That is fixed from the next release (0.40)

1 Like

Yes, parts of it would benefit to be moved to a remote component.


When is 0.39 out?

0.39 is already out.

I’m using the Broadlink RM2 to control my central A/C, via the generic thermostat component. However, it returns a temperature reading that’s roughly 4 degrees higher than the actual temperature (based on the output of the Mi Flora sensor I have nearby, the original A/C remote, as well as my personal feeling).

There are currently a couple of options to treat such a problem:

  • Simply use the temperature as is (i.e., if I want the room to be at 21 degrees, set the generic thermostat to 25)
  • Make a template sensor based on the Broadlink temperature sensor, and use that in the generic thermostat instead

I’m currently using the second option, but the need to resort to a separate template sensor is bugging me. I came up with a patch to the Broadlink sensor component to support templating directly in the configuration, like this:

  - platform: broadlink
    host: 192.168.xx.xx
    mac: 'b4:43:0d:xx:xx:xx'
    name: broadlink_rm2_temp
      - temperature: '{{ float(value) - 4.0 }}'
      - humidity

The idea is that the syntax for its configuration is backward compatible to what we have now, but a template can be applied on a per-condition basis.

I’d like some feedback, before I submit the pull request. Do you guys feel that it’s a good syntax? Is it problematic that I’m mixing the types of the monitored conditions (can be a string, can be a dict/tuple)?

1 Like

Why not just use the temp from the mi flora to control it as you’re already happy with that?

I need a separate sensor for each room. Also, I don’t want to drain my Flora’s battery, and therefore use the suggested interval of 15 minutes between probes, which might be a little too much for a thermostat…

Is there any possible way to set static IP to the RM pro and A1 if my router doesn’t support DHCP Reservation? Or to implement auto discovery?

The library supports discovery, so it is possible to add that to HA.

So just i have to edit config file and remove the Host and Mac line?

No, you have to add support for the discovery in HA. Modify the HA source code.

sorry i’m new to all this is there any instruction how can i add support for the discovery in HA?