🔹 Browser_mod - turn your browser into a controllable device, and a media_player

:tada:
Just released Browser_mod 1.1.6 allows you to set your deviceID manually!

1 Like

I have a lovelace view that calls a popup window via the reuseable browser_mod popup card that in turn also calls a browser_mod popup card via a script. This was working correctly in the prior version of browser_mod and HA 0.112 however in the latest version of 0.113 and browser_mod 1.1.6 I can’t get the popup window to show via the script. The initial reusable popup window appears but trying to trigger the popup window via the script is not doing anything. When looking at the cookbook examples it seems the config may have slightly changed but even with making this change to my config the popup window via the script isn’t working. Here is what my config looks like.

Config to trigger reusable popup card <- this is working

tap_action:
  action: call-service
  service: browser_mod.popup
  service_data:
    deviceID: this
    <<: *monitoredplug_card

Config to trigger popup via script (this is based on the cookbook example) This is called from the reusable popup card. <- this is not working

tap_action:
  action: call-service
  service: script.sonoffwasher_popup
  service_data:
    deviceID:
      - this

This was my prior config to call a popup via a script that worked in 0.112 but is not working in 0.113 (again this is what I was using in the reusable popup card to call another popup card via a script.

tap_action:
  action: call-service
  service: script.turn_on
  service_data:
    entity_id: script.sonoffwasher_popup

Is the ability to call a popup via a script from within a reusable popup card no longer doable or is my config incorrect now with the version 1.1.6?

1 Like

Just wondering - auto-closing (after a delay) of a more-info box isn’t working for me, should it ?

      - service: browser_mod.command
        data:
          command: more-info
          entity_id: camera.caller
          large: true
          deviceID:
            - 7d823333-a8333fe5
      - delay: '00:01:00'            
      - service: browser_mod.close_popup

At the moment browser_mod.popup is displaying correctly in Safari on MacOS (ie. center of browser window) like this:


When loaded through the mobile app on iOS, the popup shows as below

Anyone know how to fix this?

How do I remove the state text? It is of “type: custom:mini-media-player” that I have in a browser_mod.popup.

state_text

If it’s mini-media-player, it’s its problem, not browser mod.

On mobile, all popups are displayed in full screen. You’d need to center the buttons in the popup window somehow - it’s clear they are not exactly centered in the computer screenshot either.

1 Like

Below are 3 renderings:

  1. Left is right on the view.yaml
  2. Middle is via a browser_mod.popup
  3. Right is via a browser_mod.popup and lovelace_gen macro

Left - observe that “Off” does not show under the “Nook Speaker” media player.

Middle - again, observe that “Off” does not show under the “Nook Speaker” media player.

Right - now, observe that “Off” shows under the “Nook Speaker” media player.

How do I remove the state text? I tried the media_player idle_view options but no luck.

I will post in lovelace_gen.

Just noticed this isn’t working anymore

radio_navigate:
  alias: 'radio navigation'
  sequence:
  - service: mqtt.publish
    data_template:
      topic: "bbcrequest"
      retain: false
      payload: ''
  - service: browser_mod.navigate
    data:
      navigation_path: /lovelace/radio/
      deviceID:
        - 7d8234b8-a8284fe5

is this because a breaking change means 711114b8-a8284111 is now 711114b8_a8284111 ? I will try it! :slight_smile:

hmm it seems that my tablet now has an altogether new deviceID as well - is this something that could happen when Home Assistant itself updates?

I had a feeling that was going to be the answer, good to have it confirmed. Thanks Thomas!

It can happen from time to time.
With 1.1.6 You can go to https://your-ha-url:8123/?deviceID=711114b8-a8284111 on your tablet to reset it.

Do you know why some of your custom cards (layout-card over all) are not working on IOS 10.3.4?
I already open an issue…

I hate to ask such a noob question to what is likely very basic css and yaml formatting, but I cannot figure out how to get correct styling with browser_mod/card_mod and the popup service call. Basically when I click on an entity I get a browser_mod popup card, and that single large card is filled with several rows/columns of different buttons using a vertical-stack and several horizontal-stack cards. The problem is that I need to change the width of the single large card containing all buttons, but setting the optional parameter large: true is too wide, but large: false is just a tiny bit too narrow. I’ve tried applying style at various levels but either nothing changes or the wrong card changes. Just interested in the single large main popup card. Below is the card set to large both true/false.

Here’s part of the lovelace config; I left out the bottom 80% of that card for brevity.

- type: image
  title: null
  image: /local/ui/floorplan/hue.png
  style:
    top: 7%
    left: 60%
    width: 7vw
  tap_action: 
    action: call-service
    service: browser_mod.popup
    service_data:
      title: bitch ass hue
      large: true
      hide_header: true
      deviceID:
        - this
      card:
        type: vertical-stack
        cards:
          - type: horizontal-stack
            title: Hue Light Control
            cards:
              - type: custom:button-card
                entity_picture: /local/ui/hue/savanna.png
                show_entity_picture: true
                tap_action:
                  action: call-service
                  service: input_select.select_option
                  service_data:
                    entity_id: input_select.hue_scenes
                    option: 'Savanna sunset'
                styles:
                  card:
                    - width: 100px
                  entity_picture:
                    - height: 100px
                    - width: 100px
              - type: custom:button-card
                entity_picture: /local/ui/hue/tropical.png
                show_entity_picture: true
                tap_action:
                  action: call-service
                  service: input_select.select_option
                  service_data:
                    entity_id: input_select.hue_scenes
                    option: Tropical twilight
                styles:
                  card:
                    - width: 100px
                  entity_picture:
                    - height: 100px
                    - width: 100px

Set large to true, and then use card-mod to style the whole thing to make it smaller.

I suppose this is where my css noobness really shines; where would the style be nested in the above example config? I’ve managed to change the width of the individual buttons; the width of the single column/vertical-stack within the single large card, but never can change the actual pop-up card width (other than changing large setting).

Absolute full config share?

Has anyone had issues with browser_mod & the device light entity on a Samsung Galaxy Tab?

I have an issue where I can use the light entity to turn the tablet light off (great) but unable to turn it back on. Issue seems to persist even when I use the FKB web interface. I am able to turn the screen off but unable to turn it on.

When I ran some cheap Lenovo tablets, the screen toggle worked perfectly so I’m thinking it may be an issue with the way FKB interacts with the tablet.

Any help much appreciated!

how to install browser mode
from where do i copy files to my config.yaml

where is this:
custom_components/browser_mod/

If you’re not using HACS, there’s a green download button at the top right of the github page.
The readme tells you which files you need and where to place them.