Camera view, fully kiosk and IP bans

I’m running Fully Kiosk on a Fire Tablet.

It all works perfectly apart from when I view a specific lovelace tab, which is displaying 6 camera feeds which are (supposedly/hopefully) only pulling in an image from the www when the URL changes.

However, if I don’t fairly quickly navigate away from this camera page, things go south. If I leave that page open, I get login attempts failed galore and frequent ‘lockouts’ which don’t seem to be related to being IP banned, the connection just seems to stall and doesn’t recover. I have to quite Fully and reopen it to restablish a connection.

Disconnected: Did not receive auth message within 10 seconds

  - platform: generic
    name: Radio1
    still_image_url: "{{states.sensor.radio1_url.state|replace('400x400','288x288')}}"
    limit_refetch_to_url_change: true

Seems just like this guy’s problem…

How could I check what Home Assistant or that lovelace tab is actually doing with downloading that image…?

Hi, I have the same issue with my cameras. They are ESPHOME ESP32CAM cameras. Online, no problem. But if they go off-line, and I view the the Cameras page, I get banned even though I have everything installed to prevent banning (reverse NGINX proxy etc).

The cameras use Picture Element cards.

I have an Andoid IP camera and it is no problem.

I wonder if it is related to ESPHOME and its use of API to connect to HA??

Did you ever find a solution?

I really need some expertise from you guys. For 3 weeks now I have tried to turn my config upside-down to figure out why I suddenly started to get a lot of IP bans of devices on my home network. After I disabled IP ban threshold, main issue is the camera feed from zoneminder is stopping constantly on the tablet and Pi3b+ is running at 35-50% CPU capacity. First it started with login fails from router IP, and it went over to the tablet IP, few times from my laptop and once or twice from iphone. Seems to stop when I block HASSIO from the web. I have tried to rollback to 0.106, from 0.109 and now running 0.110. Disabled almost every integration, updated router FW, updated Zoneminder, blocked devices from the web. logging, added new users, reinstalled and disabled addons. With no luck. IP ban seems to come sporadically, whit no clear pattern.
Things I suspect could be done:

  • Clean restart of HASSIO
  • HW failure, SD failure, or the P3b+ do not have the capacity anymore
  • Certificate error
    If anyone can give me some help or pointers on way forward, it would be much appropriated.