Camera widget doesn't work


#1

What am I doing wrong when setting up the camera widget? I can see video just fine in the HA frontend.

I have tried:

driveway:
  widget_type: camera
  entity_picture: camera.driveway

driveway:
  widget_type: camera
  entity_picture: http://192.168.1.20:8123/api/camera_proxy/camera.driveway?token=<MY TOKEN>

driveway:
  widget_type: camera
  entity_picture: http://192.168.1.20:8123/api/camera_proxy/camera.driveway?token=<MYTOKEN>&api_password=<MYPASSWORD>

There’s no picture. Only an empty square.


#2

lose the token

i have
http://192.168.178.26:8123/api/camera_proxy/camera.mycam?api_password=mypw
you could also use
http://192.168.178.26:8123/api/camera_proxy_stream/camera.mycam?api_password=mypw


#3

That didn’t help. Thanks anyways!


#4

you need a working link, so try it in your browser first.


#5

So after many tries, I still can’t get it to work. I still can see the camera in HA just fine.


#6

Update. I actually got it to work. Thank you @ReneTode!


#7

How did u resolve?


#8

Can anyone please help me integrate my Chinese PTZ camera with HA?

I just cannot get it set up even when I open the link on a Web browser I get 400 error.

Thanks


#9

do you have in working in homeassistant and want it to work with the dashboard, or dont you know how to set it up in homeassistant?


#10

I have set it up using the mjpeg component but it doesn’t work as it says image not loaded. So I tried it on a Web browser and it gives me 400 error.

The link I used is http://192.168.0.25/mjpeg

I think the link is incorrect but I am not sure how to find the link. Although I know the ip address of my camera connected to my Internet at home.


#11

i think everyone is going to have a hard time helping you setup a camera when you dont have an app or pc program to set the camera up.
dont you have any kind of manual how to setup and reach your camera?

the link is incorrect for sure. first you will have to find out how to use your cam, before you can connect it to HA.


#12

I have a manual which directs me to use the “V12” app from Google playstore. And I have successfully configured it to work with my camera.

However I now need to integrate it with HA and I am having difficulties.

Do you know a way to find the streaming link ? I have tried many from this forum but none work. The closest I have got to is when I use http://my.camera’s.ip.address/mjpeg which gives me a “400 error” on my Web browser.


#13

i cant tell you anything if you dont tell which camera it is.
i would try googling on [brand] [type] [stream]
if you have no brand and or type from the cam its gonna be hard if its not in the manual.


#14

Well the camera’s brand is Apleye and it is a Chinese manufacturer.

Here s the link to the camera.


#15

i think you should contact your supplier.
it says it has pc support, so you need specs how to do that.
or an website from the manufacturer, or anything.
searching for appleye doesnt bring much.


#16

My first mistake was misspelling my api password (the password for logging into HA, if you have one) and later I also discovered I was using the wrong IP address so both mistakes were on my part.

The format that works for me is

http://192.168.139.12:8200/api/camera_proxy/camera.amcrest_camera?&api_password=APIPASSHERE

#17

since when we don’t need the token for the webcams ?


#18

@ReneTode @aimc Any downsides to setting refresh rate to 1 second to get a live view when watching the camera? It would only stream when the feed is actually called right?


#19

if you have a network thats fast enough and a device thats fast enough there should be no downside, but with wifi i havent been able to get a decent view with that.

but …

i got a much better solution for you!!

use this:

entity_picture: http://your_ip:8123/api/camera_proxy_stream/camera.your_cam?api_password=your_pw

instead of

entity_picture: http://your_ip:8123/api/camera_proxy/camera.your_cam?api_password=your_pw

and you get a stream if you have a stream in HA.

i did remove the refreh, but if the stream loses connection, it doesnt come back so i set my refresh to 3 minutes.

enjoy


#20

Hi. I have a problem also. Stream does not show in dashboard, but it shows in a tab in chrome using:
https://[my url]/api/camera_proxy_stream/camera.mjpeg_camera?token=[mytoken]&api_password=[mypass]
i have:
camera_door:
widget_type: camera
entity_picture:[myurl]/api/camera_proxy_stream/camera.mjpeg_camera?token=[mytoken]&api_password=[mypass]
refresh: 5

and - camera.door(3x3)
appreciate any help :slight_smile: