Camera widget doesn't work


#41

Thanks that worked.


#42

I have different kind of problem:
I want to install Android tablet on the wall, and have HADashboard on it.
the problem is that in HA, the cameras work perfectly. If I open HADashboard on Windows 10
it works great, and cameras too, but when I open on Android tablet, cameras don’t work
even on iPhone, HADashboard cameras doesn’t work. and everything works on PC and on Elementary OS

setup in HASSio

setup in hadash

camera_vrt:
widget_type: camera
title: vrt
entity_picture: ‘https://hassio.local:8123/api/camera_proxy_stream/camera.vrt?token=mytoken&api_password=mypassword

  • light.sonoff2, light.sonoff3, light.sonoff4, light.sonoff5, camera_vrt (2x2), camera_ulaz (2x2)

if I open link https://hassio.local:8123/api/camera_proxy_stream/camera.vrt?token=mytoken&api_password=mypassword in browser on PC stream works great
if open same stream as link on iPhone, it works great
on android (Nexus 10) if I open link there is nothing, bit with IP instead of hassio.local, it works.
but in HADashboard, it doesn’t

cameras are hikvision surveillance system

any help?

thanks in advance


#43

try using google chome on the tablet.
that should work the same as on the pc with chrome.

if it works on the pc its how it should be, so your problems are browser related.
i have no clue if there are also other browsers for the iphone (i have none) but i think so, so you could try another browser there also.


#44

It turned out that camera didn’t work because Android from some reason couldn’t resolve name, but with IP works.

thank You for help!


#45

Hi,

I got here tryin to get my camera to work in HA Dashboard.

When i go to URL in a webbrowser it works:
https://192.168.1.x:8123/api/camera_proxy_stream/camera.onvif_camera?api_password=mypassword

But not when configured in HA Dashboard.
is there a problem running through HTTPS?

dashboard config,
camera:
widget_type: camera
entity: camera.onvif_camera
entity_picture: https://192.168.1.x:8123/api/camera_proxy_stream/camera.onvif_camera?api_password=mypassword

script.htpc, script.watchtv, script.playps4, script.chromecast, script.volume7, camera.onvif_camera (2x2)


#46

yeah, https is in most cases the problem.
browsers have a problem if you try to mix https with http urls.


#47

Ok, so i should configure https for HA Dashboard to solve this? Or is there another way?


#48

the best way is to remove https from HA.
because linkin to a https site from another server is always difficult for browsers.
and several https servers on 1 device is also difficult.

if you want HA to be reached from the ouside then you create a proxyserver (like nginx) in front of your servers.
like this:


#49

Ok - Wow, thank you @ReneTode,

I will try to install the nginx proxy then! :slight_smile:


#50

Hi again, just wanted to post an update in my case,
I went with the caddy proxy addon for hassio, and it works like a charm!
Camera in HAdashboard and everything.

Thank you very much for the insight @ReneTode


#51

I installed the IP Webcam app on my Galaxy S7. I see it properly on frontend and lovelace. However, it doesn’t show in the HADashboard. My config as following:

cam_samsung:
    widget_type: camera
    title: Samsung IP Cam
    refresh: 1
    frame_style: ""
    entity_picture: http://192.168.0.150:8123/api/camera_proxy/camera.s7

layout:
  - cam_samsung(4x4)

I have also tried:
entity_picture: http://192.168.0.160:8080/
That’s the url to which it renders on the browser. No go. Neither does it work for the following:
entity_picture: http://192.168.0.150:8123/api/camera_proxy_stream/camera.s7


#52

do you have a password set in home assistant?
in that case your password is missing in the url.
http://192.168.0.150:8123/api/camera_proxy/camera.s7?api_password=your_api_password

if you have 0.77 or higher from HA a password is needed
in the configuration file from HA there need to be these lines:

http:
  api_password: !secret http_password

the url you use should work in a browser. if not then there is a problem in the HA config.


#53

That worked. Thank you so much!


#54

Btw, is there a way to not put the password in the url and put a reference instead? Something like the following:
http://192.168.0.150:8123/api/camera_proxy/camera.s7?api_password=http_password


#55

no thats not possible at the moment.
at some point the url probably wont be needed at all, but not in this release.


#56

tried a lot and the login fails are over… but then this error popped up.
I am at 77.3.
Error:
You need to use a bearer token to access /api/camera_proxy/camera.voordeur from 192.168.2.211

If i use the link in a webbrowser it gives me a “401: Unauthorized” message
Cam works on Hassio frontpage.


#57

hassio changes things for you (even if you dont want to)

check your HA config for

http:
  api_password: This_password

see if it is the same as what you use in the dashboard.


#58

It has the same. But that tip did me help to solve it anyway :slightly_smiling_face:
because of a other problem i edited my config to use the

auth_providers:
   - type: homeassistant

In stead of the

auth_providers:
   - type: legacy_api_password

This i did because of the explanaition that it had about legacy:

Activating this auth provider will also allow you to provide the API password using an authentication header to make requests against the Home Assistant API.–> This feature will be dropped in the future in favor of long-lived access tokens. <–

But changed it back and works like a charm again!
Thanx!


#59

if i have understood it correctly you could lose the whole auth_providers part and then it should configure automaticly. (and yeah the docs confuse me too and there is nowhere mentioned that anything gets automaticly configured)


#60

Hi,

Sorry for hijacking the thread but figured a bunch had already done the same :slight_smile:
I too am having issues with displaying a camera image in my dashboard.
I have read through this thread and think I have tried everything but to no avail.

The url I use works in my browser but not as a widget in my dashboard, just get a blank square.
Here is the conf I use:

uterum:
widget_type: camera
refresh: 10
entity_picture: http://hassIP:8123/api/camera_proxy/camera.altankamera?api_password=PASSWD
title: Uterum

Same result with:

uterum:
widget_type: camera
entity_picture: http://hassIP:8123/api/camera_proxy_stream/camera.altankamera?api_password=PASSWD
title: Uterum

Any ideas/tips?

!Update:
Never mind, I got it working 5min after I posted here :smiley:
My problem had nothing todo with HA or dashboards, it was just a Networking issue, my display was simply not allowed to access the IP I had specified.