Can add IKEA RODRET Wireless dimmer to Zigbee ZHA, but cannot see button press in logbook?

Seems a lot of folk having issues with IKEA RODRET Wireless dimmer.

I can add the which to homeassistant, but home assistant is not recognising button press events in device logbook.

Home Assistant is working for IKEA STYRBAR Remote control and logbook shows button press events. Many other Zigbee devices connected.

Home Assistant is running on Raspberry Pi 4 4GB, in a container from image homeassistant/raspberrypi4-homeassistant:stable. Using Zigbee CC2531 USB device as controller and ZHA integration.

USB was plugged into USB2 port directly on the Raspberry Pi (passed through to container using docker). Tried connecting USB into USB HUB, then USB hub into USB2 port. Zigbee still works, and no changes to IKEA RODRET Wireless dimmer.

Not tried moving from ZHA to zigbee2mqtt. Would prefer not to, due to large number of Zigbee devices in use.

Very likely that you are simply having EMF/EMI/RMI interference issues with the Zigbee Coordinator and/or Zigbee Router, or might also be that you do not Zigbee Router devices within close range in your Zigbee network, so before you do any deeper troubleshooting (as in digging through debug logs) be sure that you are first following these best practise tips → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Seen others reported it as working fine after changing the battery and following the community best practice setup guide (at least making sure both using a long USB extension cable to a USB 2.0 port or USB 2.0 hub to avoid interference as well as making sure have enough Zigbee Router devices on the same Zigbee network), so read and make an effort to follow those best practices.

Reference:

Without looking at any debug logs I would in addition replace that old CC253x (CC2530/CC2531) based Zigbee Coordinator which runs an outdated Zigbee stack (that does not get any newer firmware updates) as it is no longer recommended for ZHA or Zigbee2MQTT. Refer to → https://www.home-assistant.io/integrations/zha#known-working-zigbee-radio-modules and https://www.zigbee2mqtt.io/guide/adapters/

If have issues it is recommended to upgrade Zigbee Coordinator firmware regardless of which radio adapter/model you have, (though if have an older adapter then it is unlikely there are any updates).

I would therefore suggest you begin by migrating to a more modern Zigbe radio adapter with a newer Zigbee Coordinator NCP firmware before troubleshooting that issue any deeper. So suggest you either a Texas Instruments CC2652P or an EFR32MG21 based (preferably with an external antenna like the Sonoff ZBDongle-P or the Sonoff ZBDongle-E, which by the way can both be repurposed as powerful Zigbee Router devices if flashed with alternative firmware). Check out → Zigbee buyer's guide

It is really easy to migrate to a new Zigbee Coordinator radio adapter if using the ZHA integration, see → https://www.home-assistant.io/integrations/zha#migrating-to-a-new-zigbee-coordinator-adapter-inside-zha (though do make sure to create and save a Zigbee network backup before the migration). (Migrating if using Zigbee2MQTT is more work but also doable → https://www.zigbee2mqtt.io/guide/faq/).

If you get the same issue using a newer Zigbee Coordinator with later then you should report it by posting an issue under Home Assistant core repoitory on GitHub with a debug log for diagnostics from the ZHA integration. Read → https://www.home-assistant.io/integrations/zha#reporting-issues

Again, while it might not seem related, it is highly recommended you regardless of the outcome from the above suggestions, do read and try to follow the best practice tips in this community guide linked below (which for example advice always using a long USB extension cable to a USB 2.0 port or USB 2.0 hub as well as making sure have enough “known good” Zigbee Router devices on your Zigbee network):

No button-events might be the reason of an incomplete pairing of the device, which is a bit tricky when you dont know the process:

Pairing the device with the zigbee controller (after pressing the button on the ikea device 4 times quickly) is only half the work that has to be done.

In the 2nd step you have to trigger the configuration in the zigbee-device and then hold the ikea-button for 10 seconds.

After that everything should be fine.

Same issue also for me with ZHA. remote recognized in discovery mode but i’m stucked in the ‘configuring’ phase. any idea?
Screenshot_20240327_232633

Edit: i tried holding for 10 sec the pairing button after ZHA has discovered it but nothing happened

I hadn’t realised that this needed a 2 stage pairing. Had me stuck for a couple of hours, don’t know how many pairing cycles I went through before I found this information. Thank you @Tortenboden

Following this process, 4 presses to initially pair and then a 10 second hold sorted out both devices straight away for me.

Now to sort out the bindings…

:upside_down_face: it’s not working… Can I kindly ask you detailed steps to follow?

Currently I have:

  • clicked pair button 4 times
  • led started blinking fast
  • led started blinking slow
  • device appeared in the device list In zha (even if I haven’t clicked on “add devices”)
  • led turned off
  • I started pressing the pair button for a couple a seconds ( 10 I guess)
  • led started blinking
  • I clicked on “add devices” from zha
  • in less than a second the device appeared configured
  • at the same time the led turned off
  • I released the pair button

After that, the device has entities but buttons doesn’t work. I can’t see any event in the logs. Clicking the “indenfy” button raise an error.

What did I do wrong?

For me the following worked: I added a (IKEA) lightbulb to the ZHA, next I put the Rodret in pairing mode (whilst close to the lightbulb and not on the same floor as the Sonoff Zigbee dongle) . It was found instantly and works like a charm! I assume communication through the lightbulb must have done the trick.

Used hardware:
Sonoff Zigbee 3.0 USB Dongle Plus (Texas instruments chip)
IKEA Tradfri Bulb GU10
IKEA Rodret dimmer

1 Like

Thanks mate,

This was a real pain to get working

1 - Add device to ZHA via reset the device with 4 quick presses and you’re left with a semi configured device (ignore the logbook that’s comes from step 2)

2 - Pair with a Trafadi bulb. Hold remote close to the bulb and hold the pairing button for 10 seconds. From the device info page you’ll notice the the general configuration remains incorrect but we now have events being fired to HA as per the logbook

3 - Attempts to unbind the remote from the bulb fail so remove the device completely from ZHA

4 - Reset and repair as per step 1 and everything works fine :man_shrugging:

I have 5 more to now add … Wish me luck :grimacing:

OK I think I’ve solved it !

On the second Rodret I managed to get it paired much easier without needing the bulb

1 - Pair and Add device to ZHA - Rodret just hangs in the configuring device phase

2 - On the ZHA device page hit reconfigure whilst issuing another repair on the Rodret

QED :grimacing:

Good luck

thanks for the reply. the process is very non-deterministic :sweat_smile: after step 2 i had to reset the the remote (without a repair) 5/6 times to complete the process, that is by clicking 4 times the pair button near my ZHA coordinator.

edit: i paired another remote and after step 2 all was working without the linked bulb issue. :see_no_evil: as a programmer myself, this is disturbing

Yup. It’s completely random - there’s no set pattern

I’ve got 3 of the 6 remotes working and gave up with the others until I have time to kill