Can not contact Broadlink RM mini3 to Hass

Hi everyone,
I have problem with RM mini3 (black) FCC ID : 2ACDZ-RMMINI3-RM S/n RM61H0221965
Home Assistant 0.108.9 . I try to connect RM mini 3 for the first time. I has static IP for this RM mini3 .

I had insert code in configuration.yaml :



  • platform: broadlink #RM mini 3
    mac: ‘24:DF:A7:7A:7C:A3’


  • platform: broadlink #RM mini 3
    mac: ‘24:DF:A7:7A:7C:A3’
    timeout: 15
    retry: 5

Then I goto developer-tools/service and do that :

Service Data (YAML, optional)

entity_id: remote.broadlink

When I click: Call Service, then click remote tivi to RM mini 3, there no notice. I check lamp in RM mini 3, it not light. Broad mini 3 hub still work in my phone.
Then I check in State panel : [remote.broadlink] unavailable , anh no any signal code of remote.

And there no folder .storage in config .

Please help me!

There are other threads that have information on this problem.
Search for it and you will find the other thread(s).

You have to unlink it from app and run a python script to add it to your local network.

If I unlink it from app and run a python script to add it, then Mini RM3 still can use in App Broadlink?

That is why I’m buying a second to experiment with

1 Like


I’m new to Home Assistant and getting my head around everything. I am having the same issue as the OP.

I have tried searching for the thread that you speak of, but without any luck? Is there any chance you could provide a link to it please?


This is the post that explains how to do it.

1 Like

Thank you for taking the time to post the link, its appreciated.

I understand most of it, but unfortunately I have no idea how to create a python script! Sounds way above my level of expertise. I dont suppose you can point me in the right direction on how this would be done?

I love the idea of using HA but unfortunately if I can not get my Broadlink remote to work, its a bit of a deal breaker - which is a shame.

Thanks again for your assistance.

I haven’t got around to do it myself yet.
Since it means you need to delete it from the cloud I have not done it yet.
I bought a second RM 3 mini that I now can in HA and get that to the same position as the other, then I will just switch.
The new worked flawlessly in HA from start. Must be because it has not been on the cloud.

I have no previous knowledge of python so I have only read and tried my way forward so far, but not actually done what “needs” to be done.


I actually read somewhere else earlier today (unfortunately I can not find the information again), where somebody stated that if you de-link the device from the Broadlink app and reset the device, you can then re-register it on the network through the app but DO NOT connect it to the cloud.

Unfortunately though as far as I can tell the Broadlink app requires you too sign in before you can register the device and then automatically connects to the cloud.

I’m trying a few different things - some people have said its a firmware issue on the newer models - do you know if its possible to install an older firmware on these devices?


I don’t know.
All I know is the one I bought used is a RM3, the one I had problems with is a RM4.
When I added the RM3 I went through the process but did not go any further than I needed.
Meaning when I had it on my network I closed the app and started using broadlink manager and it worked.

I have read some posts about the problem being fixed on the new version of Home Assistant.