Cannot access hassio-boot partition


I cannot access the hassio-boot partition on the SD card after flashing the correct image for my RPi 3B+ using etcher.

Tried on macOS as well as Windows.

Try on linux if possible, I think MAC and Windows need some special drivers/software in order to recognize the boot partition.

Finally showed up but apparently its called hassos-boot.

Saving my-network with the following contents to ~/CONFIG/network did not boot up my Pi


# Uncomment below if your SSID is not broadcasted




I wouldn’t need to put that file in there if not for this issue, where it supposedly cannot recognize the Ethernet link…

I strongly suggest to not use Wireless connection for your Home Assistant server, always go wired unless it’s not possible. Do you have no possibility to put it on a wired connection?

Did you read the post from the mod that this is not an issue but normal behaviour?

Its literally connected to Ethernet but it takes forever to boot and is stuck here:

Honestly this would be a non-issue if add-ons were supported on “Manual installations”, then I could’ve used my Pi 4.

With it’s stuck there, do you mean you can’t access the web interface at all?

Whats the reason for not using your Pi 4 for this?


Some progress have been made but the web UI is still not reachable

Overclocked and runs off an SSD, with Plex and related installed. Not sure I’d be able to pull that off with this hack.

Ah I see, I think there’s a workaround for this but haven’t tried it myself.

Can you sucessfully ping the Home Assistant server at I’d wait for an hour or maybe even overnight and check again if the web UI is still not available. The first time it takes some time.

Yes. I don’t see any indication that its trying to download anything either. The Ethernet indicator isn’t even blinking rapidly.

If this doesn’t work, I might go back to venv on the other Pi, the only issue is the installation of add-ons.

You know you can do a supervised install on raspbian (or other linux OS you use on your pi) ?

Then you have your add-ons.

1 Like

I managed to do just that. I need some help setting up add-ons. For example, I want to set up this plugin.

Am I doing this correctly?

The camera configuration needs to go in your configuration.yaml, not on the card.

Is this okay?

That looks ok. Validate your configuration and restart HA to get it working.

I did that but I couldn’t get an image to show up. Probably screwed up again in some place.

Can you see your picture if you manually browse to ? Maybe open a new topic for your camera, as I don’t have a camera myself, and nobody will look for a camera problem under this topic name.

Yeah I can.

Just for your information, this is not an add-on, you don’t need Home Assistant Supervised for this, this is just a standard configuration, which is supported by every installation type.