Cannot connect to host - ssl:default [Name does not resolve]

Tags: #<Tag:0x00007f3268ca9c10>

Hello and thank you in advance for your assistance,

I have HassOS installed on a Raspberry 3B.
Recently I noticed I was receiving this error message, for various integrations.
I believe it means that HA does not have a proper internet connection, eventhough it has a wired connection directly from my router (Experia Box v8). So I thought it might of been something in my HA configuration / one of my integrations, so I reflashed my SD card with HassOS, a brand new install, and immediately receive the same error for the default weather integration.
So that leads me to believe there is something wrong with my connection.
Therefore I’ve tried following Network documentation, trying to set a static IP address, I’ve tried doing that through Supervisor and through nmcli, neither resulted in a fix.
I’ve tried solutions provided in this topic (Cannot connect to host version.home-assistant.io:443), such as setting 1.1.1.1 as a secondary DNS in my router.

All of which didn’t result in a fix and the error persisted.

Does anyone have some kind of solution (at this point I am willing to try anything, so even if you’re not sure, feel free to let me know).

Once again, thank you in advance.
Kind Regards,

Gijs

I would appreciate any suggestion, as currently everything is erroring.
Hopefully someone has some information.

Kind regards,

My Home Assistant Core (Docker) install has started doing this in the last few days too… strange.

Maybe this will help: Suddenly HASS cannot connect to internet ressources (DNS issue?)