Cannot get Aeon Labs Zwave Minimote working


rPi3 with AIO installer, 0.36.0

I’ve searched and messed with this for a while, but I cannot get the Aeotec DSA03202 Minimote to with with HA. Z-Wave itself is working fine, I have an Aeotec Smart switch that works perfectly from HA.


  usb_path: /dev/ttyACM0
  config_path: /srv/homeassistant/src/python-openzwave/openzwave/config/
  polling_interval: 10000

Paired with OZWZP, changed to scene mode, confirmed the remote LEDs are showing red+blue when pressing button. Also in OZWCP I see this in the log:

2017-01-19 18:57:18.113 Info, Node004, Received Scene Activation set from node 4: scene id=1 now. Sending event notification.

tail OZW_Log.txt shows:

2017-01-19 19:30:27.635 Detail, Node004,   Received: 0x01, 0x0a, 0x00, 0x04, 0x00, 0x04, 0x04, 0x2b, 0x01, 0x01, 0x00, 0xda
2017-01-19 19:30:27.635 Detail,
2017-01-19 19:30:27.635 Info, Node004, Received Scene Activation set from node 4: scene id=1 now. Sending event notification.
2017-01-19 19:30:27.636 Detail, Node004, Notification: SceneEvent

So I am pretty sure all that is OK. I see nothing in home-assistant.log though.

I have tried putting this in configuration.yaml also:

automation 10:
- alias: Minimote Button 1 Pressed
    platform: event
    event_type: zwave.scene_activated
      entity_id: Node004
      scene_id: 1
    service: switch.toggle
    entity_id: switch.humidifier1

Clearly I am missing something… help?

Try dropping the entity_id: Node004 since that’s not how HA knows your Minimote.

Ok, that worked. Thanks!

So I guess that means with two remotes: they’re doing the same thing since you can’t differentiate between them?

I’m sure it’s possible, I just don’t know how to find out the actual entity ID for the remote :wink:

Edit: Looks like there’s an object_id that can be found on the console. That page says the console, so I poked in the systemd logs (since that’s where the console output goes in my case) and found both the object_id and entity_id of my remote.

Awesome, that worked! I found it in /var/log/syslog

Thanks for the help!

Jan 21 09:40:51 raspberrypi hass[19869]: INFO:homeassistant.core:Bus:Handling <Event zwave.scene_activated[L]: entity_id=aeotec_dsa03202_minimote_6, scene_id=1, object_id=aeotec_dsa03202_minimote_6>


`automation 10:

  • alias: Minimote Button 1 Pressed
    platform: event
    event_type: zwave.scene_activated
    scene_id: 1
    object_id: aeotec_dsa03202_minimote_6
    service: switch.toggle
    entity_id: switch.humidifier1 `

Hi All, Just to help out others having the same issue. I spend hours trying to get the timing right when pairing the z-wave device and quickly trying to change the configuration from “group” to “scene” via the Open Zwave Control Panel. Each time the dialog drop down box would refresh back to “Group”. I was about to give up when I read somewhere else that the remote is in “Scene” mode when both the red and blue light flash at the same time each button press. So after you have pressed “Learn” on the remote and tried changing to “Scene” mode check if the both lights come on each button press before you get frustrated and spend hours!!!

Then in Home Assistant only the device was listed in the Developer States < > tool. The state did not change for each button press, so check the bottom of the Z wave log file to see if that node ID is recognising button presses. Once that is working then you are good to go with the automation script similar to above. Good luck!!

1 Like

UPDATE: I removed my minimote and re-added it and now it works. I didn’t change anything else so not sure what was wrong with the first attempt. Feel free to ignore the rest of this message…just leaving in case some other newbie runs into issues in the future and finds this thread :slight_smile:

I can’t get my minimote to work and I don’t understand this post but I think I am having the same issue that joelphillips had.

My minimote was included with no issue. I have a node added and the node entity id is zwave.aeotec_dsa03202_minimote

I have configured the automation as follows.

- id: mini_1_pressed
    alias: 'Minimote Button 1 Pressed'
      - platform: event
        event_type: zwave.scene_activated
          entity_id: zwave.aeotec_dsa03202_minimote
          scene_id: 1
      - service: homeassistant.toggle
          entity_id: light.color_light

When I press the minimote 1button it flashes both the blue and the red lights but nothing happens.

There is no activity in the OZW log.

I figured my node may be bad so I tried remove node but when I do nothing happens. The node remains.

Am I supposed to configure 250:Mode to Group or Scene?
I think I need scene mode since my automation is looking for scene_id: 1
I have tried both I think. I change the config parameter in the zwave configuration UI and I select “Set Config Parameter” I have tried both Group and Scene but the results are the same.
Is there a way to check the current parameter setting?
When I send the parameter the UI just returns to the “Group” setting.

How can I check the firmware on the minimote? There is a note in the config that says

Enable selective Group Mode or Scene Mode when Button is in Use. NOTE: Minimote firmware 1.17 or higher is required, firmware 1.19 is highly recommended.

The minimote was working fine on SmartThings so I am sure it works.

How can I remove the node? Remove node in the Configuration UI doesn’t work. Can I just remove it from the entity_registry.yaml file ?
Does it also exist in home-assistant_v2.db (grep finds it in there) I don’t have any clue how to manage this sqllite3 DB ? Still something I need to research.
I ask because I am wondering if I should exclude/include the minimote, perhaps it wasn’t paired correctly? I suspect this isn’t the case but I don’t know what else to do at this point.