Cannot get my RF transmitter to talk to my projector screen

Hello! This is my first proper post - apologies if it is full of etiquette errors!

I’m a noob when it comes to HA. I haven’t done any programming for years - the last time I coded anything it was in Turbo Pascal version 7 for DOS. So I’m a bit out of touch to say the least.

I’ve done OK so far. I have a solid HA setup, running my lights (non-Hue), Harmony Hub, a few smart power outlets, etc. and everything is working well. I’m pleased with my scripts.

But I’ve hit a wall. My projector screen is a key element to my setup and it is controlled with an RF remote. Like this one:


I have added an RF transmitter and receiver to my Pi and set everything up using @brusc’s video. Everything seems to be working fine. I have successfully managed to sniff the codes from the remote, and I have created a switch in HA that transmits them. I can tell that the transmitter is transmitting correctly as the receiver can pick up the transmissions.

The problem is that the screen doesn’t respond. Nothing. I’m sure distance isn’t an issue, there is barely a metre between the transmitter and the screen’s receiver. I have a jumper wire acting as an antenna. My code is fine. I am completely stumped.

So here I am - asking for help. Anyone have any ideas?

1 Like

I would recommend increasing the number of times each code is repeated… I use the following

platform: rpi_rf
gpio: 17
protocol: 1
pulselength: 186
code_on: 4281651
code_off: 4281660
signal_repetitions: 20

I have one in particular that will only trigger after 30 or more reps

hope that helps!

Thanks for the suggestion @cclckc! I’ll give it a go and let you know how I get on.

No luck I’m afraid. :tired_face: Even at 30 reps, nothing. Not a sausage.

1 Like

Try 50 reps

50… 60… Nothing. I’m so frustrated! I’ve solved every problem I have come up against along the way and this one has me completely stumped!

Is it possible that the screen is simply not compatible? I can’t see how if it is just a case of sending an RF signal…

Does other RF stuf work with your setup? Otherwise it could be that your screen is indeed not compatible… @TD22057 advised this (RTL-SDR) in a other topic.

Thanks for the pointer. Looks interesting, but sounds a little bit beyond my capability. I struggle to see how there can be a compatibility issue, surely a 433hz signal is a 433hz signal? Regardless of where it comes from.

This guy seems to have managed to achieve exactly what I am trying to do:

His screen is a Homegear 100 which, as far as I can work out, uses the same remote as my unbranded screen. So there’s must be a way!!


I really dont know. Maby a bad transmitter?

Did you try his tutorial?

Let me know if it works.

Have you tried adding a antenna to the transmitter?

Other topic suggesting using the better RX and TX.

I orderd them to try it out.

I don’t think it is a duff transmitter, the receiver can see it transmitting when I run my script.

I installed everything pretty much the same way Magen did, it looks like he followed @bruhautomation’a video like me. I haven’t done the section where he faffs around with permissions yet as I’m not sure they are relevant to my installation, but perhaps I should take a closer look at that.

My RX and TX are the better ones, I bought those on the recommendation of @bruhautomation and I have since read in a lot of places that that was a good move. I am using a jumper wire cut to 173mm for an antenna.

I have ordered a couple of the cheap RF plugs that everyone seems to use with HA, probably as a result of @bruhautomation’s video. So That should help me to narrow down the problem.

I’ll let you know how I get on!

Well the RF plugs arrived - the same as the ones Ben uses in his video. And hey presto, I had the codes sniffed and HA controlling them in less than five minutes. No problem at all.

So that tells me for certain the the RF receiver and transmitter are both set up and working correctly, no doubt about it.

Which I suppose puts me back at square one. I have sniffed the codes for the projector screen. I can transmit the codes for the projector screen. But the projector screen does nothing.

If the original RF remote and the Pi are both transmitting the same codes, over the same frequency, I can’t fathom how the screen’s receiver knows any difference. Could it be signal strength? The Pi is control the RF sockets all over my house, no problem at all. The projector screen receiver is only a few metres from the Pi.

I am stumped! Please, somebody help me before I find myself sobbing into a large vodka…

1 Like

Woow that sucks big time… I received the better tx rx set yesterday. Going to test them this weekend.

I really dont know what is going on with your screen. maby you could try other Pi sniffing software?? First making it work without HASS. maby they read other values…

Edit: 1 vodka for me please

Thanks @VGE.

I have tried sending codes directly from the command line. The codes do transmit, but the screen sits there ignoring them. My thread doesn’t seem to be getting a lot of attention, other than yours so maybe I am at a dead end with the screen. Perhaps buy a new one!

p.s. When you set up your new TX and RX, make sure you put a 173mm jumper wire on the antenna connection - it really increases the range.

Yea nobody is responding… It shoud freaking work right? Maby ask in the Raspberry forum?

Awesome tip, do you remove the plastic or keep it on?

Well I popped it off but I have no idea if that made any difference…!

1 Like

I cant even get the outlets to work with the better rx/rf… Im using the guide from BRUH Automation . :expressionless:

Any tips?

We’re going a bit off topic here, and I think that may be a little frowned upon! Maybe someone might let me know the correct protocol…

At which point in the process do you find a problem? Have you been able to sniff the remote codes? If so, is your config ok? Or is HA showing an error?

Dud you get this working mate? I’ve got the same screen and also sniffed the codes but screen isn’t responding.

I’ve only only installed the rf transmitter so not sure it’s defo working yet but just came across this thread

2019-04-21 08:50:23 - [INFO] rpi-rf_receive: 884180 [pulselength 197, protocol 1]

Is what I’ve sniffed but like you the screen isn’t responding… Did you get it working @oldturnip?

Hi @Rich_Paul.

I did get it working in the end, and it was a stupid, stupid, schoolboy error on my part! Turns out the screen operates on 315MHz frequency and I was using 433MHz TX and RX.

I ordered a 315MHz pair, and hey presto. Job done.

That said, I have moved away from HA since, just because memory card reliability was getting on my nerves. I may well try HA again using a cheap second hand Mac Mini or something similar, when I have a few quid and some time on my hands.

In my current set up, I’m using an RM Pro+ just to operate the screen, using an Alexa routine to ‘watch a movie’, which brings the screen down and sorts out the lighting and AV. But I think you can integrate and RM Pro into your HA setup. You just have to make sure you get one that does both 315MHz and 433MHz. If you’re in the UK, you’ll need to order one from Europe I think.

Hope that helps!