Cannot install Mosquitto addon, reason may be that I used MQTT integration before


I have a number of Home Assistant installations. On some I cannot install Mosquitto. I found that these installations were having MQTT integration in use already (with an external broker).
I cannot install Mosquitto even if I uninstall the MQTT integration.

Network settings, DNS and firewall are OK. Everything else works fine.

I get this error when trying to install the Mosquitto add-on:
Can't install homeassistant/amd64-addon-mosquitto:6.4.0: 500 Server Error for http+docker://localhost/v1.43/images/create?tag=6.4.0&fromImage=homeassistant%2Famd64-addon-mosquitto&platform=linux%2Famd64: Internal Server Error ("error parsing HTTP 408 response body: invalid character '<' looking for beginning of value: "<html><body><h1>408 Request Time-out</h1>\nYour browser didn't send a complete request in time.\n</body></html>\n"")

HTTP 408 is usually a client-side timeout error. There is an invalid character ‘<’, check if any names you are using contain invalid characters.

My problem looks like this one: Official add-ons won't install

I have a number of installations, and only on those which used the MQTT addon before, it fails…

But I’m still struggeling with a solution… Also installation via Terminal (ha addons install core_mosquitto) leads to the same error.

I actually solved this by moving my VM to a segment that was not “secured” by my firewall. Everything worked fine there.
So it seems to be a network related problem and is solved.
I hope it helps others who are in the same situation.