Cannot install/update addons

Whenever I try to install an addon, I get this error message in the supervisor log: “[] ‘AddonManager.update’ blocked from execution, no host internet connection”.

Since I have this error when trying to reinstall zwavejs, and I really depend on it for a lot of my house stuff, this is a major issue for me now!

Does anybody have a clue what can be the issue here? I indeed have internet connection, port forwarding active and working (443 to 8123 internally).

I ended up reinstalling Home Assistant and restore a recent backup; that did the trick.

I have this problem, too. :\

Hi panhans, if you can restore a recent backup, reinstalling is not a big deal after all. Sometimes you’re better off doing that, than spending hours fixing the unfixable :wink: .

Yep, I know. But fortunatly I was able to resolve that issue. After checking ha core and addons via commandline without any error, I linked my dns configured in my router to the one of my internet provider.
AdGuard that runs on my ha instance blocked the update and installation of addons. So now I just go with official filter lists. But it was necessary to restart the host or flush the dns cache of my pi manually.

1 Like

Same her. I paused the protection in adguard home, restart the hassio host, installed all updates, start the protection and reboot again. It’s just a workaround, but i don’t want to delete the unofficial filter lists.

In my case, this message appears due to the fact that when contacting, it issues hCAPTCHA, so HAOS does not receive the desired response “NetworkManager is online”.

This is my problem. Having connected via VPN, everything works correctly.

Question: how to convince hCAPTCHA that I am not a bot and remove my IP from blocking?

This might be related to…/#1483

Had same problem on a restore, apparently the multiple listed DNS entries didn’t come across correctly.

I simply reset the DNS to and a reboot fixed it all.


Having this same issue after upgrading to 2202.6.0 and trying to run the upgrade to 2202.6.1 gives this error and fails

Fixed my issue also

Thank you for this thread. After reading @mgithens1 solution I set my DNS to my router IP. This solved my issue and if i change my DNS on my router home assistant will not need to be changed.

Thank You

I am now just getting this issue, how did you change the DNS?

System ==> Settings ==> Network

I had to specify the ip of Hass and enter the DNS as the router IP.
Hope this helps

1 Like

My issue was worse than that, I had to update NeworkManager for it to work

Confirm, you need set DNS server: Settings > System > Networks > eg WLAN0 > ipv4 > eg

thanks a mil resolved my issue too. whoooooohoooooooo

Same problem I had. Without restoring backup (if available that solves this), I think the following is much more easier to use:

I managed to disable the host_internet check: ignoring the internet_host condition.

ha jobs options --ignore-conditions internet_host

The network info still the same, but I was able to install all addons I have:

➜  ~ ha network info | grep internet
host_internet: false
supervisor_internet: true

and to reset it back to normal, after addon update completed:

ha jobs reset

I hope it helps…

Setting DNS to Router ip worked for me. Thanks

This worked great. Koszi szepen!