Home Assistant Community Add-on: AdGuard Home

4.1.6 is working a treat!

4.1.6 is working well for me too… now I have to figure out my old config

4.1.6 works :slight_smile:

Had version 4.1.2

Tried to update, but got an error:

‘AddonManager.install’ blocked from execution, no host internet connection

Tried to delete and reinstall, but still got the same issue.

Also before i removed the add-on it seemed it was trieng to load something and dns was showing in the web UI.

So now I got stuck… tried to get a snapshot from beofre. but the oldest I got was 21hr old… seems not to be working.

Got a HA blue btw.

Had your same issue, I went to Supervisor → System → Reboot host and I was able to access the internet again.

1 Like

It does not seem to work.

also followed these steps Cannot install/update addons - #3 by panhans

I changed my primary dns on the router to 2nd was already set to rebooted host. opened incognito browser and tried again… still same error. :frowning:

Hey All,

It seems that DNS rewrites are no longer working. I use them to redirect to internal IP addresses when inside my local network. Has anyone else experienced this? I’m running 4.1.6 of the add-on, which is the latest. If I query a domain from inside my network that has a rewrite, I get the public IP.

1 Like

After the update to 4.1.6, it seems that is the only address that can be pointed to AdGuard.

Before we were able to use around 5 different addresses, including the home assistant address.

Currently, despite the fact I indicated ports in the configuration, ports are not redirected.
Here is the output of the docker ps command

CONTAINER ID   IMAGE                                             COMMAND                  CREATED          STATUS          PORTS                                       NAMES
2527bfa6d9d0   ghcr.io/hassio-addons/adguard/amd64:4.1.6         "/init"                  35 seconds ago   Up 35 seconds                                               addon_a0d7b954_adguard

Any idea of what could be done ?

Something is not right with the latest upgrade.
Restored my AdGuard to 4.0.0 and now all the ads are blocked again. …

1 Like

Same. I tried to upgrade to 4.1.6 and adguard stopped working. Didn’t have time to diagnose - logs suggested it started ok but all dns queries to it were timing out. Rolling back to 4.0.0 fixed it.

I saw a note that 4.0.0 had breaking changes, but it caused no problems when I upgraded to it. I can’t see what’s different in this latest update that might be breaking things. Any ideas?

4.0.0 works
4.1.2 totally doesn’t work and wouldn’t even start the console properly
4. 1.6 I thought works because it started the console but still didn’t work.

Had to roll back to 4.0.0

Is there an easy way to restore? I installed AdGuard Home via the supervisor and don’t see an easy way to go back even though I have a snapshot. The snapshot appears to contain only data.


I just restored the snapshot with only the checkbox for adguard selected, and after a reboot it said it was back to v4.0.0
The way I saw it, it was already stuffed and I couldn’t make it any worse so I gave it a go. And it worked!

It appears you need to Enable the DHCP server before you can add static clients. That makes it impossible to migrate an existing list of static clients without risking that they temporarily get a wrong (dynamic) IP address.

I tried to outsmart the UI by running the DHCP server on first, set up the static clients, then switch it to my LAN IP. But it won’t allow that either because it rejects client IP’s outside of its own IP range.

That said, even if the UI allowed me to do what I wanted, it’s cumbersome to have to add each client one by one.

Is there a way to import existing static leases from a file? Or what is the best practice to migrate from a different DHCP server?


I managed to get it working by adding “manually” the iptables rules.

Care to share more details?


I added those rules ( is the IP of the Adguard container)

-A POSTROUTING -s -d -p udp -m udp --dport 53 -j MASQUERADE
-A DOCKER ! -i hassio -p udp -m udp --dport 53 -j DNAT --to-destination
-A DOCKER -d ! -i hassio -o hassio -p udp -m udp --dport 53 -j ACCEPT
1 Like

Thanks! That worked perfectly. While I wasn’t having major problems with 4.1.6, there was something odd where turning off filtering didn’t seem to work properly.

1 Like

It works perfectly with iptables -t nat before all rules :wink:

Thank you @Jmi