Cannot integrate Hive devices

I have been struggling, unsuccessfully, to integrate my Hive devices into HA. I read that Hive is already integrated in HA and that I just need to add a hive section with my Hive username and password in my configuration.yaml. I did this after I setup my Hive account and configured my hub and devices (I do not have two factor authentication enabled on my Hive account), and rebooted my HA. No devices or entities appeared, I could see no mention of Hive in the HA Logs, home-assistant.log, or in the System Supervisor log. I had no idea if it failed to log into Hive or even tried to. I can log into my Hive app and Hive webpage and see my devices ok.

I started reading through the Hive Integration thread in the HA Community forum and followed the instructions to create a config/custom_components/hive directory and populate it with a number of files from github ( . After doing this I could see an expected message about using a hive custom component in the HA Log. But still no devices.

I then removed that hive folder and installed HACS. I then used HACS to install the Hive Custom Component. Then when I go to Configuration – Integrations and click + to add integration Hive is not there to select.
I have restarted Home Assistant every time the instructions required it. have tried rebooting the RasPi as well.

Can anyone see where I’m going wrong? Am I missing out on some crucial step that’s not obvious to me? Is there something that the Hive integration depends on that I have not installed/configured?
I have Home Assistant 0.118.3 on RasPi4
My Host System is Operating System HassOS 4.17, Deployment production
Supervisor Version 2020.11.0

My configuration.yaml is very uncomplicated, the hive username and password are indented two spaces, I have tried putting the lines at the end and at the beginning of configuration.yaml, nothing works.

My configuration.yaml:

# Configure a default setup of Home Assistant (frontend, api, etc)

# Hive Configuration
  username: [email protected]
  password: yyyyyy_Yyyyy

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  ip_ban_enabled: true
  login_attempts_threshold: 5

Hi Ricta, I also came here to say this.

I have Home Assistant Core 0.117.6 on a Raspberry Pi. I added my username and password to configuration.yaml and initially the entities appeared and I could add them to a dashboard.

Then I added a solaredge integration, which worked, but my Hive entities suddenly broke. Even if I remove the solaredge lines, the Hive entities do not come back. I have gone back to a bare configuration, restarted, rebooted, but every time the Hive entities do not appear.

Logging with “debug” level shows the hive lines are being picked up. But changing to a wrong password/username does not throw up any errors. Which sounds like your case as well.

I have checked (grep hive *) in .storage and no hive entities are listed, so they are not there but disabled in the registry.

I’m out of ideas of how to get home assistant to actually pick up the hive integration, or even further debug what the next step would be besides throwing the install away and starting from scratch again.


Hi, I have had Hive integration working for some time but over the last 2 days, it seems to have stopped working. There was an issue in 0.115 but was resolved in 0.116 and now sadly another issue has arisen.

From what I can tell both your configs look correct. I remeber api isnt offical so its may be that Hive have broken somehting again and your experiences are simply related to bad timing.

Hoping someone else can help

found this post, yes the integraion is down at present

Thanks for the pointer to that thread, Neil. I updated the Hive Custom Component via HACS to beta 22. I kept the username and password lines in configuration.yaml, cleared browser cache and rebooted HA.
I can now see my devices for the first time since I started trying a week ago.