Cannot load history anywhere in HA - "loading state history..."

I’ll add a me too; on a HASSOS VM with Hassio 80.3. Was not working on 80.2. Upgraded and it worked initially, but a second restart of HA and it stopped working.

[edit]I think it may be some sort of caching issue.

Bugger it here is me saying 0.80.3 is the solution, and suddenly it stops working for me too.

Clearing my browser cache fixed it though (chrome, win10)

same here…

I have updated to 80.3 and history is working now but History component only shows up on my phone browser.
I can’t get it working on a pc browser (chrome or firefox) even in private browsing. is hosted on an Intel NUC.

You are right: only on mobile phone! :thinking:
With Firefox and Chrome on linux no joy!

I have posted again on the closed issue on github, issue 17563.
Please do the same so some developer is aware of it.

If you click on history and then reload the webpage it then loads.

1 Like

This does work sometime, its seems if it going to load it loads quickly, but most of the time it never loads

Hmm this works for me 100% of the time if i refresh the page. Im running HA in a docker container on a debian vm thats hosted on windows 10 machine with a i5 and ssds.

Well, 0.81.0 works perfect for me!

Same problem on HassOS V0.81.6 on Pi 3B+ 32bit, did a new install last week on new SD card did not help, just says “Loading state history” for ages then shows “Error while loading this panel” on Chrome and Firefox.

Update: I have been using MariaDB add on, stopped using it, went back to default DB setting, now it’s working again.

I am on HassOS V0.82.1 on Pi 3B+ 32bit, DB runs on NAS, tried Opera, Chrome, IE and Edge.

The history component just says "Loading State History … " and never loads, after some time message “Loading State History …” disappeared but no data displayed.
After this => Map, Records, Configurator,, Configurator components are not possible to open - only the wheel it turning, Dev-info log is not displayed, other dev-components does not work as well => reboots on its own.
After that - everything works again, except history component.

I´ve reconfigured history.yaml and recorder.yaml as well, there are no includes nor excludes.
Sensor templates seems to be working.

Any attempt to open history causes Home Assistant reboot.
There are no errors in log.

Is there any way how to have the history working again?

I have the same problem on my Raspberry Pi 3B+ 32bit with HassOS and HA 0.82.1
The browser shown the history after a ‘long’ time but it’s impossible to interact with the page, the browser is slowed down by the web page.

same on my System. Raspberry Pi 3B+ 32bit running on 0.82.1)
sometimes i see the history graph, but then i can not scroll down on the page and the browser window freeze, or the graph is not not loading.
In both cases i have to restart the browser (Chrome latests Version).
Home screen is loading normal, also all other functions are working, only the history is dead.

my history have atm 4gigs

Same problem here

same here, when I try to open history system, is going to crash
my db is 825MB

I am also having same issues with HA which is causing my HA to hang.
I have a raspberry Pi 3b+ with HASSIO running HassOS 1.13 (64 bit) and home assistant 84.6 when i select the history tab the processor temperature increases towards 60 degrees with an increase in processor load and the whole thing hangs and I have to unplug the pi and plug it back in.
When i plug it in it shows the increase in temperature and processor load then the return to reasonable level. If i ping the IP i get significant delays in response from typical 3.5ms increasing to thousands of ms. i cannot SSH in when it gets in this state.
There are no entries in the log to show any problems, but it seems to get in a state where the processor is unable to cope with the demands.

Any ideas gratefully received.

Switching to an external database rather than sqlite helps, if you haven’t done it already.

Still have this problem… Also my db is read only. Is this connected?