Cannot load history anywhere in HA - "loading state history..."

Did not work for me

Define “did not work”.

Where are your logs?

Have you cleared your browser cache?

It just does not show up with the history_graph component. No error in log. I cleared browser cache and still happening.

History seems to be working. history_graph(s) however do not.

Same here!
Just updated to 0.80.3.

Always “loading state history”: even with a new brand browser.

Same for me on HA 0.80.3
The single graph sensor works perfect, but the history_graph: component remains in “Loading History”. They worked perfect in HA 0.79

I’ll add a me too; on a HASSOS VM with Hassio 80.3. Was not working on 80.2. Upgraded and it worked initially, but a second restart of HA and it stopped working.

[edit]I think it may be some sort of caching issue.

Bugger it here is me saying 0.80.3 is the solution, and suddenly it stops working for me too.

Clearing my browser cache fixed it though (chrome, win10)

same here…

I have updated to 80.3 and history is working now but History component only shows up on my phone browser.
I can’t get it working on a pc browser (chrome or firefox) even in private browsing. is hosted on an Intel NUC.

You are right: only on mobile phone! :thinking:
With Firefox and Chrome on linux no joy!

I have posted again on the closed issue on github, issue 17563.
Please do the same so some developer is aware of it.

If you click on history and then reload the webpage it then loads.

1 Like

This does work sometime, its seems if it going to load it loads quickly, but most of the time it never loads

Hmm this works for me 100% of the time if i refresh the page. Im running HA in a docker container on a debian vm thats hosted on windows 10 machine with a i5 and ssds.

Well, 0.81.0 works perfect for me!

Same problem on HassOS V0.81.6 on Pi 3B+ 32bit, did a new install last week on new SD card did not help, just says “Loading state history” for ages then shows “Error while loading this panel” on Chrome and Firefox.

Update: I have been using MariaDB add on, stopped using it, went back to default DB setting, now it’s working again.

I am on HassOS V0.82.1 on Pi 3B+ 32bit, DB runs on NAS, tried Opera, Chrome, IE and Edge.

The history component just says "Loading State History … " and never loads, after some time message “Loading State History …” disappeared but no data displayed.
After this => Map, Records, Configurator,, Configurator components are not possible to open - only the wheel it turning, Dev-info log is not displayed, other dev-components does not work as well => reboots on its own.
After that - everything works again, except history component.

I´ve reconfigured history.yaml and recorder.yaml as well, there are no includes nor excludes.
Sensor templates seems to be working.

Any attempt to open history causes Home Assistant reboot.
There are no errors in log.

Is there any way how to have the history working again?

I have the same problem on my Raspberry Pi 3B+ 32bit with HassOS and HA 0.82.1
The browser shown the history after a ‘long’ time but it’s impossible to interact with the page, the browser is slowed down by the web page.