Cannot setup spotify integration

So as the title says the Spotify integration is not working for me,

I completed the steps as shown in the how-to, but it just gives me a blank card that says spotify.

The error from the logs is:

Logger: homeassistant.helpers.config_entry_oauth2_flow

Source: helpers/

First occurred: 1:37:50 PM (1 occurrences)

Last logged: 1:37:50 PM

Timeout resolving OAuth token:

Any idea?

Did you ever get this sorted? I’m getting the exact same issue. A blank box after I enter credentials and click “link account”.

Can’t seem to find any help anywhere online for this specific issue.

Not sure if its the same issue I had but I managed to fix it by deleting the Spotify integration that had no entities then restarted HA and added it again and this time it worked for me and the Spotify media player entity was created correctly.

My issue is I don’t even get as far as the integration being added, so there’s nothing I can delete.

Have you followed all the steps and created an app on the Spotify Developer Dashboard?
Also I found that you need to get the redirect URIs correct otherwise it doesn’t work.

I have the following entered for the Redirect URIs on Spotify:
http://{my internal IP address of HA}:8123/auth/external/callback

Yes got both of them in the Redirect URIs.

This is what I get after clicking “Link Account”…

Another thing to check is that the My Home Assistant link is correctly setup with the internal link to your HA. Use the URL below and it should open up a page with the link to your HA instance. If it is incorrect, fix it up and then try again.

You mean at this step?..

That’s the one.
Make sure the link is one that will open HA.
Mine is set to my internal HA IP address and port number:

http://{my internal IP address of HA}:8123

Yes I’ve tried the internal IP as well as homeassistant.local:8123, as well as my domain name that I’ve set up to allow remote access to my HA, and all of them allow me to get to the next step but it’s when I click “link account” it just spins saying “Loading next step for Spotify” for a minute, then it goes blank.

I’ve checked the Logs and I’m getting “Timeout resolving OAuth token”

Hmmm…looks like you are not alone with this issue and no one seems to have found a solution yet :frowning: