Can't access Configurator using Nabu Casa Remote Control

I just switched to Nabu Casa Remote Control of my HASSIO setup but I cannot for the life of me get Configurator to work. I just get the following when accessing https://xxxxremoteurlxxx.ui.nabu.casa:3128:

**xxxxremoteurlxxx.ui.nabu.casa**  took too long to respond.

My configurator config is as follows:

{
  "username": "user",
  "password": "pass",
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "allowed_networks": [
    "ip-address"
  ],
  "banned_ips": [],
  "banlimit": 0,
  "ignore_pattern": [
    "__pycache__"
  ],
  "dirsfirst": false,
  "enforce_basepath": false,
  "notify_service": "persistent_notification.create",
  "sesame": "",
  "loglevel": "error"
}

Any ideas what I can do to get it to work using Remote? Thanks…

i think its normal, since its running on another container, its a different network

This is currently not possible

Hi. thanks for the inputs. So I’d need to still run it on my duckdns with 3128 and 8123 open I guess?

It would be a great feature if the local files could be sent to the remote host to edit using the Remote control functionality.

i recommend using a VPN :slight_smile:

2 Likes

I hope this can be added as it’s a significant inconvenience. All the ‘OPEN WEBUI’ buttons are broken in the addons.

Back to VPN.

They are not Broken, they didn’t work before also if you didn’t open the ports in your firewall…

1 Like

what about trying it as an iFrame?

Still need ports open or vpn

Remote control works like a charm - access to my iFrames (Web-Configurator, TasmotaAdmin, Zigbee2MQTT-Admin, etc.) would be great too - sadly no VPN access out of my office possible…

It seems like this has been resolved with the latest updates, as you can now hit “Open Web-UI” while using Nabu Casa, and configurator launches. Does anyone know how to specify the URL of the menu link to work as well? I think hassio.local: is the issue, but I don’t want to hardcode it to the remote link for when I am at home. Here is the link in my configuration.yaml:

  configurator:
    title: Configurator
    icon: mdi:wrench
    url: http://hassio.local:3218

If you open the configurator in a separate tab/window you can get the url.

Press the cog top right > New Tab

Thanks Skully. That worked. For reference, here is my new link in the configuration.yaml:

  configurator:
    title: Configurator
    icon: mdi:wrench
    url: /api/hassio_ingress/{your identifier here}/

We’ll see if it works when I am local too.

When you say {identifier} do you mean the unique identify of my configurator addon? Because it doesn’t have a unique identifier any more with ingress.

N36, I mean the ingress identifier (I think that’s what it is) but basically the last part of the url that Skully pointed me to.

Update: The configuration I previously shared only works when accessing Home Assistant via Nabu Casa. I get a “401: Unauthorized” when accessing Home Assistant locally.

Great thanks waltino4, got it now. I’ll give it a try locally and remotely tomorrow and report back.

I tried your method but my window looks like this:

So it works but it isn’t optimal.

You can wait for 0.92.0 which should be out on Wed for an easy checkbox to add ingress addons to the side bar, or if you can not wait, below is the correct code to add it to the side bar (using iframes wont work, as you saw):

#In configuration.yaml
panel_custom:
  - name: hassio-main
    sidebar_title: Configurator
    sidebar_icon: hass:settings
    js_url: /api/hassio/app/entrypoint.js
    url_path: configurator
    embed_iframe: true
    require_admin: true
    config:
      ingress: core_configurator
1 Like

Where would I find that checkbox? Don’t see anything in the release notes.