Home Assistant Community

Can't access hassio.local:8123, only numerical IP address

#1

So I’ve got a hassio instance running on my Rasperry PI3 okay. Yesterday (the day of the install) I could access hassio.local:8123 on my PC okay, but my android phone only worked with it’s local ipaddress (can’t remember what it was yesterday).

Today I rebooted my router and not my PC will only work with 192.168.1.109:8123 and not hassio.local:8123 (guessing a new address was assigned by router) This wouldn’t be a problem except when I go to configurator tab in hassio it says " hassio.local ’s server IP address could not be found." which I’m guessing means it won’t work because only the numerical IP address works. Oh and the adress bar in chrome is “http://192.168.1.109:8123/configurator”.

Can anyone lend a helping hand as to how I can access configurator and the text based IP address for my hassio instance? I’ve tried different browsers and incognito mode by the way

#2

You should go into your router and assign an IP to your Pi that way it will not change if you reboot your router.

#3

Already done :slightly_smiling_face: but that doesn’t help my current problem.

#4

Can anyone even point me in a direction or some tests to do? I’ve been searching all morning and afternoon in this forum and Google and still no joy. I’ve added “192.168.1.109 hassio.local” to my hosts file on my windows machine and it’s made no difference by the way.

#5

I dont know anything about HassIO and how it makes its name that way? presumably in its own hosts file or similar.

Can you get onto it via SSH, and verify it has a hostname set?

also, on your windows machine, any changes you make to the hosts file, you also need to flush the dns resolver cache, otherwise it makes no difference what you do in the hosts file
open a cmd nad do ‘ipconfig /flushdns’ to make sure its flushed

from windows, if you ping ‘hassio.local’, what does it show? it should show the hosts file entry (if you have it in there)
What does it show if you do not have the hosts file entry? remember to flushdns after you save the hosts file again

to ping in windows/linux, open cmd prompt, and simply type ‘ping hassio.local’ without the quotations

#6

From the note at the bottom of this.

If your router doesn’t support mDNS, then you’ll have to use the IP address of your Pi instead of hassio.local .

Edit: Oh. You could get there originally.

So That’s not it.

#7

Typically the hassio.local address is broadcast across the network using the zeroconf/bonjour/avahi/mDNS services. Your client/router would need to be able to receive this broadcast and know what to do with it to create the DNS entry. Additionally, rebooting your router may have killed the current DNS entry, and HA hasn’t “re-broadcast” to force the router to re-add the name.

More Info Here

This “auto DNS” stuff is pretty unreliable and very limited though (can’t use over a VPN, etc). I would suggest creating a static DNS entry either on your router, or on your computer’s host file… something like HASS.local (not the same as the mDNS one to reduce conflict issues).

I would also try what elPaulio suggested for some additional troubleshooting.

#8

I have a fritz box as a router, and that gives out another domain.
Mine is accessible with http://hassio.fritz.box and not with hassio.local

#9

Thanks all, just about to commence battle with it. As a temporary bodge, is there a way to force the configurator addon to use 192.168.1.109 instead of hassio.local? I’m assuming that’s what giving this problem: (image attached)

#10

I haven’t SSH’s into it yet and haven’t setup Samba shares on my PC. Ironically that was why I wanted to access the the configurator to set up. I can’t access the addon option either because of a bug when you disable discovery mode (and can’t enable it until I access the configurator).

Pinging 192.168.1.109 gives a good result. Pinging hassio.local gives “Ping request could not find host hassio.local. Please check the name and try again.”

putting my entry in the hosts file makes no difference (with and without ipconfig /flushdns being done with and without PC rebooted). Below is a screenshot of my hosts file.

#11

In an annoying bit of irony… you have to edit the UI config so the link points to the IP rather than the DNS name. See the bottom of: https://www.home-assistant.io/addons/configurator/

I would try with something other than hassio.local (ie hass.local) to prevent any conflict with the auto-generated DNS entry in the future. Not sure if that may be the reason it doesn’t work.

#12

@dave_sausages Did you manage to get this working? I’m having the same issue.
Not sure if related, but devices that can’t access hassio.local also can’t access files in the ‘local’ directory (/config/www). I don’t mind the direct IP workaround, but access issues break the UI in my case.

#13

Same here too. Seems the DNS broke right after I set a static IP on the Pi.

#14

This means that you need to configure your DNS server to respond to that static IP. When you use DHCP it automatically registers itself in DNS, and when you are using static, most of the time you have to register it yourself.

#15

You need a bonjour/zeroconf service on your machine with the browser.

An Apple device which should have bonjour already running, hassio.local should resolve.

On Linux you can use Avahi, and I believe it’s possible on Windows also.